Version bump for 2.18.1
authorSaleem Abdulrasool <compnerd@gentoo.org>
Tue, 17 Apr 2007 03:58:26 +0000 (03:58 +0000)
committerSaleem Abdulrasool <compnerd@gentoo.org>
Tue, 17 Apr 2007 03:58:26 +0000 (03:58 +0000)
Package-Manager: portage-2.1.2.4

x11-libs/vte/ChangeLog
x11-libs/vte/files/digest-vte-0.16.1 [new file with mode: 0644]
x11-libs/vte/vte-0.16.1.ebuild [new file with mode: 0644]

index 51232c2fb74cbe1704eff7493ac3c44de61b79e0..495243206c1f48d5fd29f8e46bc15192b2a2dce9 100644 (file)
@@ -1,6 +1,11 @@
 # ChangeLog for x11-libs/vte
 # Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/vte/ChangeLog,v 1.145 2007/03/27 14:36:15 dang Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/vte/ChangeLog,v 1.146 2007/04/17 03:58:26 compnerd Exp $
+
+*vte-0.16.1 (17 Apr 2007)
+
+  17 Apr 2007; Saleem Abdulrasool <compnerd@gentoo.org> +vte-0.16.1.ebuild:
+  Version bump for 2.18.1
 
   27 Mar 2007; Daniel Gryniewicz <dang@gentoo.org> vte-0.16.0-r1.ebuild:
   Remove pcre option; it's broken
diff --git a/x11-libs/vte/files/digest-vte-0.16.1 b/x11-libs/vte/files/digest-vte-0.16.1
new file mode 100644 (file)
index 0000000..a4948ac
--- /dev/null
@@ -0,0 +1,3 @@
+MD5 ceec938666899c1e67e1ce4dd358c753 vte-0.16.1.tar.bz2 1097978
+RMD160 4a28e21b15e19f5a8aebd7d76639fb1bb890e865 vte-0.16.1.tar.bz2 1097978
+SHA256 6e4dd96d5234f0571bf5456aecb9b8d02e3acaedafac2add07c2728e25bf2a76 vte-0.16.1.tar.bz2 1097978
diff --git a/x11-libs/vte/vte-0.16.1.ebuild b/x11-libs/vte/vte-0.16.1.ebuild
new file mode 100644 (file)
index 0000000..689b71b
--- /dev/null
@@ -0,0 +1,53 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/vte/vte-0.16.1.ebuild,v 1.1 2007/04/17 03:58:26 compnerd Exp $
+
+inherit eutils gnome2 autotools
+
+DESCRIPTION="Xft powered terminal widget"
+HOMEPAGE="http://www.gnome.org/"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+# pcre is broken in this release
+IUSE="debug doc python opengl"
+
+RDEPEND=">=dev-libs/glib-2.9
+       >=x11-libs/gtk+-2.6
+       >=x11-libs/pango-1.1
+       >=media-libs/freetype-2.0.2
+       media-libs/fontconfig
+       sys-libs/ncurses
+       opengl? (
+                               virtual/opengl
+                               virtual/glu
+                       )
+       python? (
+                               >=dev-python/pygtk-2.4
+                               >=dev-lang/python-2.2
+                       )
+       || ( x11-libs/libX11 virtual/x11 )
+       virtual/xft"
+
+DEPEND="${RDEPEND}
+       doc? ( >=dev-util/gtk-doc-1.0 )
+       >=dev-util/intltool-0.35
+       >=dev-util/pkgconfig-0.9
+       sys-devel/gettext"
+
+DOCS="AUTHORS ChangeLog HACKING NEWS README"
+
+pkg_setup() {
+       G2CONF="$(use_enable debug debugging) $(use_enable python) \
+                       $(use_with opengl glX) --with-xft2 --with-pangox"
+}
+
+src_unpack() {
+       gnome2_src_unpack
+
+       epatch ${FILESDIR}/${PN}-0.13.2-no-lazy-bindings.patch
+
+       cd ${S}/gnome-pty-helper
+       eautomake
+}