net-misc/tinc: version bump to 1.0.29
authorAnthony G. Basile <blueness@gentoo.org>
Sun, 9 Oct 2016 14:57:43 +0000 (10:57 -0400)
committerAnthony G. Basile <blueness@gentoo.org>
Sun, 9 Oct 2016 16:15:15 +0000 (12:15 -0400)
Package-Manager: portage-2.2.28

net-misc/tinc/Manifest
net-misc/tinc/tinc-1.0.29.ebuild [new file with mode: 0644]

index e0876693a02f0d2f2fdef38fe80acb698ecd2ab4..893b77cb27e6654294e5e30c2a3a5f473574ec94 100644 (file)
@@ -1,2 +1,3 @@
 DIST tinc-1.0.28.tar.gz 488837 SHA256 0b502699360f09ce2128a39cf02abca07bfc699fc02ce829b3a90cf5e1e8b344 SHA512 b449f59e45b72a75271d54af1b9359f69040e81960533ca70d2a1f84b6bb913ffe1e6d11265eb1d11b5577855ed495898ef3c387d14268b159f352c8e754f5ec WHIRLPOOL 9558328fc01e9ef716330167c958bdfe45c12365dccdd3dc8c878a1dd122a0710d41e434a4ec0f5a54427b2b04fd7204f5225bef8c64ddd9fde7e6d800e7a996
+DIST tinc-1.0.29.tar.gz 493335 SHA256 0357017c6ffbbe1b2088c28fa684d2b119afa1086f363c503d06e8f6faa72a78 SHA512 230f3ff4c86d9ebed6e350f3ec92e931d83f94e6b9c4821bec745dddc2d33997e776bf3cd2a8b9e261b2f0b2df2ed8b5406bfa40bae08696304f650de9f34ef3 WHIRLPOOL 9825337a4622bd9461c027767e701b3934ef422beb10a06b801e005549b7b2ff944d4609591667efc994d14b002db937658209a8eb9f363a868373ebfdd0603e
 DIST tinc-1.1pre14.tar.gz 696109 SHA256 e349e78f0e0d10899b8ab51c285bdb96c5ee322e847dfcf6ac9e21036286221f SHA512 dfc54a91fd40826b108e9cbae43da42462eb51bb7ad16ac040cb1b262b5510eb6884b1f1dbe0541a3b1631213f70cc678593d1ba51ebdf150c3f6968030b9291 WHIRLPOOL 63c8229c667e461ad20c118d233a2abfe598cc95698b8c83e5f8b598657ca298ea0cdc20432ab2d084fd4a06129a5884e91eb445f4c7204be3798d1fb4dec2f8
diff --git a/net-misc/tinc/tinc-1.0.29.ebuild b/net-misc/tinc/tinc-1.0.29.ebuild
new file mode 100644 (file)
index 0000000..19f1e15
--- /dev/null
@@ -0,0 +1,48 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="6"
+inherit systemd
+
+DESCRIPTION="tinc is an easy to configure VPN implementation"
+HOMEPAGE="http://www.tinc-vpn.org/"
+SRC_URI="http://www.tinc-vpn.org/packages/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="libressl +lzo uml vde +zlib"
+
+DEPEND="
+       !libressl? ( dev-libs/openssl:0= )
+       libressl? ( dev-libs/libressl:0= )
+       lzo? ( dev-libs/lzo:2 )
+       zlib? ( sys-libs/zlib )"
+RDEPEND="${DEPEND}
+       vde? ( net-misc/vde )"
+
+src_configure() {
+       econf \
+               --enable-jumbograms \
+               --disable-tunemu  \
+               $(use_enable lzo) \
+               $(use_enable uml) \
+               $(use_enable vde) \
+               $(use_enable zlib)
+}
+
+src_install() {
+       emake DESTDIR="${D}" install
+       dodir /etc/tinc
+       dodoc AUTHORS NEWS README THANKS
+       doconfd "${FILESDIR}"/tinc.networks
+       newconfd "${FILESDIR}"/tincd.conf tincd
+       newinitd "${FILESDIR}"/tincd-r1 tincd
+       systemd_newunit "${FILESDIR}"/tincd_at.service "tincd@.service"
+}
+
+pkg_postinst() {
+       elog "This package requires the tun/tap kernel device."
+       elog "Look at http://www.tinc-vpn.org/ for how to configure tinc"
+}