compile and install contribs libraries
authorAlastair Tse <liquidx@gentoo.org>
Tue, 9 Sep 2003 20:50:29 +0000 (20:50 +0000)
committerAlastair Tse <liquidx@gentoo.org>
Tue, 9 Sep 2003 20:50:29 +0000 (20:50 +0000)
x11-libs/wxGTK/Manifest
x11-libs/wxGTK/files/digest-wxGTK-2.4.1-r1 [new file with mode: 0644]
x11-libs/wxGTK/files/wxGTK-2.4.1-contrib.patch [new file with mode: 0644]
x11-libs/wxGTK/wxGTK-2.4.1-r1.ebuild [new file with mode: 0644]

index 5adc13894e34f5d6ee89d731ed13cd1256b06d9e..b51972876f027e79eac2d0b30507a3299a76c447 100644 (file)
@@ -1,7 +1,7 @@
-MD5 57cce05d8446210bd3049d2b2de4f226 ChangeLog 5731
+MD5 ef6b35f71a48f4fee7e42b1005c622be ChangeLog 5918
 MD5 4fca175f747a090fd2b7b8ce22fbc06d metadata.xml 162
 MD5 6c6dee6bc743f89e1ac66340295156a2 wxGTK-2.4.0.ebuild 2695
-MD5 9c5a58f9b775de0f199601cd4ec7bd06 wxGTK-2.4.1-r1.ebuild 2665
+MD5 213c1f64404d93b4bc3926b3f0e049e4 wxGTK-2.4.1-r1.ebuild 2676
 MD5 3798e7b17ac804c8c12b6ca2448b82c3 wxGTK-2.4.1.ebuild 2495
 MD5 16ea0622454512339b2c613af61a9aa4 files/digest-wxGTK-2.4.0 65
 MD5 86ee1d94ec752953d445a824f643fef5 files/digest-wxGTK-2.4.1 65
diff --git a/x11-libs/wxGTK/files/digest-wxGTK-2.4.1-r1 b/x11-libs/wxGTK/files/digest-wxGTK-2.4.1-r1
new file mode 100644 (file)
index 0000000..742d7c0
--- /dev/null
@@ -0,0 +1 @@
+MD5 937c299de177990908770989206b7d8c wxGTK-2.4.1.tar.bz2 5348194
diff --git a/x11-libs/wxGTK/files/wxGTK-2.4.1-contrib.patch b/x11-libs/wxGTK/files/wxGTK-2.4.1-contrib.patch
new file mode 100644 (file)
index 0000000..6332e0e
--- /dev/null
@@ -0,0 +1,13 @@
+--- wxGTK-2.4.1/contrib/src/xrc/Makefile.in    2003-09-09 16:46:13.468009816 +0100
++++ wxGTK-2.4.1/contrib/src/xrc/Makefile.in    2003-09-09 16:46:50.065446160 +0100
+@@ -17,7 +17,9 @@
+ HEADER_SUBDIR=xrc
+ EXPAT_DEFS=-I$(expat_dir)/xmlparse -I$(expat_dir)/xmltok
+-EXPAT_OBJECTS=xmltok.o xmlrole.o xmlparse.o
++EXPAT_OBJECTS=$(expat_dir)/xmltok/xmltok.o \
++         $(expat_dir)/xmltok/xmlrole.o \
++         $(expat_dir)/xmlparse/xmlparse.o
+ HEADERS=xh_all.h xh_bttn.h xh_chckb.h xh_chckl.h xh_choic.h xh_combo.h \
+         xh_dlg.h xh_gauge.h xh_html.h xh_menu.h xh_notbk.h xh_panel.h \
diff --git a/x11-libs/wxGTK/wxGTK-2.4.1-r1.ebuild b/x11-libs/wxGTK/wxGTK-2.4.1-r1.ebuild
new file mode 100644 (file)
index 0000000..42857e2
--- /dev/null
@@ -0,0 +1,96 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/wxGTK/wxGTK-2.4.1-r1.ebuild,v 1.1 2003/09/09 20:50:24 liquidx Exp $
+
+DESCRIPTION="GTK+ version of wxWindows, a cross-platform C++ GUI toolkit."
+SRC_URI="mirror://sourceforge/wxwindows/${P}.tar.bz2"
+HOMEPAGE="http://www.wxwindows.org/"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc"
+IUSE="nls odbc opengl gtk2"
+
+DEPEND="virtual/x11
+       media-libs/netpbm
+       media-libs/giflib
+       media-libs/libpng
+       media-libs/jpeg
+       media-libs/tiff
+       sys-libs/zlib
+       odbc? ( dev-db/unixODBC  )
+       opengl? ( virtual/opengl )
+       gtk2? ( >=x11-libs/gtk+-2.0* dev-libs/libunicode ) : ( =x11-libs/gtk+-1.2* )"
+
+RDEPEND="nls? ( sys-devel/gettext )"
+
+src_unpack() {
+       unpack ${A}
+       epatch ${FILESDIR}/${P}-wxpython1.patch
+       epatch ${FILESDIR}/${P}-wxpython2.patch
+       epatch ${FILESDIR}/${P}-contrib.patch
+}
+
+src_compile() {
+       local myconf
+       myconf="--enable-gif --with-libtiff --with-zlib --with-libpng \
+               --enable-png --with-libjpeg"
+
+       #Note: pcx image support enabled by default if found.
+       #Also, all wxWindows gui features are enabled by default. If you
+       #want to build a smaller library you can disable features by adding
+       #the appropriate flags to myconf (see INSTALL.txt).
+
+       #The build tools include a --with-freetype option, however it doesn't
+       #seem to be implemented in the source yet.
+
+       # Note: ODBC support does not work with --enable-unicode
+       #       We only use --enable-unicode (if at all) when we use
+       #       gtk2.
+
+
+       if [ `use odbc` ] && [ ! `use gtk2` ]; then
+               myconf="${myconf} --with-odbc"
+       elif [ `use odbc` ] && [ `use gtk2` ]; then
+               ewarn ""
+               einfo "you cannot specify both odbc and gtk2"
+               einfo "Choosing gtk2 over odbc"
+               einfo "re-run with USE=\"-gtk2\" to enable odbc"
+               ewarn ""
+               sleep 5
+               myconf="${myconf} --without-odbc"
+       else
+               myconf="${myconf} --without-odbc"
+       fi
+
+       use opengl \
+               && myconf="${myconf} --with-opengl" \
+               || myconf="${myconf} --without-opengl"
+
+       myconf="${myconf} --with-gtk"
+
+       # here we disable unicode support even thought gtk2 supports it
+       # because too many apps just don't follow the wxWindows guidelines
+       # for unicode support.
+       #
+       # http://www.wxwindows.org/manuals/2.4.0/wx458.htm#unicode
+       #
+       # ref #20116 - liquidx@gentoo.org (07 May 2003)
+
+       #use gtk2 && myconf="${myconf} --enable-gtk2 --enable-unicode"
+       use gtk2 && myconf="${myconf} --enable-gtk2"
+
+       econf ${myconf}
+       emake || die "make failed"
+       
+       cd ${S}/contrib/src 
+       emake || die "make contrib failed"
+}
+
+src_install() {
+       einstall || die "install failed"
+       dodoc *.txt
+       
+       cd ${S}/contrib/src
+       einstall || die "install contrib failed"
+}