app-eselect/eselect-repository: Bump to v1
authorMichał Górny <mgorny@gentoo.org>
Fri, 22 Sep 2017 04:17:48 +0000 (06:17 +0200)
committerMichał Górny <mgorny@gentoo.org>
Fri, 22 Sep 2017 04:24:24 +0000 (06:24 +0200)
app-eselect/eselect-repository/Manifest [new file with mode: 0644]
app-eselect/eselect-repository/eselect-repository-1.ebuild [new file with mode: 0644]

diff --git a/app-eselect/eselect-repository/Manifest b/app-eselect/eselect-repository/Manifest
new file mode 100644 (file)
index 0000000..2392ccd
--- /dev/null
@@ -0,0 +1 @@
+DIST eselect-repository-1.tar.gz 5378 SHA256 d73d4ab5fd525f3504814b25087a051bde1b358033f996e10eca3d5eeeeabf22 SHA512 7f985c3abe3fa02dfe44aade71583e7280c4757470fe8bf43de8fcc2403e8b924d9b0af104e926a2b3cd79a92b440570347db511767c908dda087ccc9f3aba6e WHIRLPOOL 8ad0d21452a0094007b795aa105312110404dca33ee8c8e3c189b08f9fbad7759c2f1fe6572839c06cb7bdbaa39740195d674e72dc72debf6f118570d40daec2
diff --git a/app-eselect/eselect-repository/eselect-repository-1.ebuild b/app-eselect/eselect-repository/eselect-repository-1.ebuild
new file mode 100644 (file)
index 0000000..6a49b07
--- /dev/null
@@ -0,0 +1,38 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{3_4,3_5,3_6} )
+inherit python-single-r1
+
+DESCRIPTION="Manage repos.conf via eselect"
+HOMEPAGE="https://github.com/mgorny/eselect-repository"
+SRC_URI="https://github.com/mgorny/eselect-repository/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="${PYTHON_DEPS}
+       app-admin/eselect
+       net-misc/wget"
+
+src_compile() {
+       MAKEARGS=(
+               PREFIX="${EPREFIX}/usr"
+               SYSCONFDIR="${EPREFIX}/etc"
+               SHAREDSTATEDIR="${EPREFIX}/var"
+               ESELECTDIR="${EPREFIX}/usr/share/eselect/modules"
+       )
+
+       emake "${MAKEARGS[@]}"
+       python_fix_shebang eselect-repo-helper
+}
+
+src_install() {
+       emake "${MAKEARGS[@]}" DESTDIR="${D}" install
+       keepdir /var/db/repos
+       einstalldocs
+}