net-proxy/haproxy: Fix 32-bit build
authorSam James (sam_c) <sam@cmpct.info>
Fri, 8 May 2020 03:01:18 +0000 (03:01 +0000)
committerMatt Turner <mattst88@gentoo.org>
Sat, 23 May 2020 19:19:17 +0000 (12:19 -0700)
Links against libatomic on 32-bit non-x86 arches.

Closes: https://bugs.gentoo.org/668002
Closes: https://github.com/gentoo/gentoo/pull/15704
Signed-off-by: Sam James (sam_c) <sam@cmpct.info>
Signed-off-by: Matt Turner <mattst88@gentoo.org>
net-proxy/haproxy/haproxy-2.0.14-r1.ebuild
net-proxy/haproxy/haproxy-2.1.4-r1.ebuild

index 7e2cb38725c6805f443848f0fb18f895a81ee469..d1c45681b5608eaecf7b299ea7911239dacc5809 100644 (file)
@@ -97,12 +97,17 @@ src_compile() {
        # For now, until the strict-aliasing breakage will be fixed
        append-cflags -fno-strict-aliasing
 
+       # Bug #668002
+       if use ppc || use arm || use hppa; then
+               TARGET_LDFLAGS=-latomic
+       fi
+
        if use prometheus-exporter; then
                EXTRA_OBJS="contrib/prometheus-exporter/service-prometheus.o"
        fi
 
        # HAProxy really needs some of those "SPEC_CFLAGS", like -fno-strict-aliasing
-       emake CFLAGS="${CFLAGS} \$(SPEC_CFLAGS)" LDFLAGS="${LDFLAGS}" CC=$(tc-getCC) EXTRA_OBJS="${EXTRA_OBJS}" ${args[@]}
+       emake CFLAGS="${CFLAGS} \$(SPEC_CFLAGS)" LDFLAGS="${LDFLAGS}" CC=$(tc-getCC) EXTRA_OBJS="${EXTRA_OBJS}" TARGET_LDFLAGS="${TARGET_LDFLAGS}" ${args[@]}
        emake -C contrib/systemd SBINDIR=/usr/sbin
 
        if use tools ; then
index 7e2cb38725c6805f443848f0fb18f895a81ee469..d1c45681b5608eaecf7b299ea7911239dacc5809 100644 (file)
@@ -97,12 +97,17 @@ src_compile() {
        # For now, until the strict-aliasing breakage will be fixed
        append-cflags -fno-strict-aliasing
 
+       # Bug #668002
+       if use ppc || use arm || use hppa; then
+               TARGET_LDFLAGS=-latomic
+       fi
+
        if use prometheus-exporter; then
                EXTRA_OBJS="contrib/prometheus-exporter/service-prometheus.o"
        fi
 
        # HAProxy really needs some of those "SPEC_CFLAGS", like -fno-strict-aliasing
-       emake CFLAGS="${CFLAGS} \$(SPEC_CFLAGS)" LDFLAGS="${LDFLAGS}" CC=$(tc-getCC) EXTRA_OBJS="${EXTRA_OBJS}" ${args[@]}
+       emake CFLAGS="${CFLAGS} \$(SPEC_CFLAGS)" LDFLAGS="${LDFLAGS}" CC=$(tc-getCC) EXTRA_OBJS="${EXTRA_OBJS}" TARGET_LDFLAGS="${TARGET_LDFLAGS}" ${args[@]}
        emake -C contrib/systemd SBINDIR=/usr/sbin
 
        if use tools ; then