media-fonts/exljbris-free: Port to EAPI 7
authorDavid Seifert <soap@gentoo.org>
Sat, 19 Oct 2019 16:44:36 +0000 (18:44 +0200)
committerDavid Seifert <soap@gentoo.org>
Sat, 19 Oct 2019 16:44:36 +0000 (18:44 +0200)
Bug: https://bugs.gentoo.org/697302
Package-Manager: Portage-2.3.77, Repoman-2.3.17
Signed-off-by: David Seifert <soap@gentoo.org>
media-fonts/exljbris-free/exljbris-free-20100320.ebuild

index bb67c66505a0ddda90f0a646cad33be1842fa7f0..520bbcad0634442653892e9c04fbe3d7963d53e4 100644 (file)
@@ -1,13 +1,14 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=0
+EAPI=7
 
 inherit font
 
 DESCRIPTION="Beautiful free fonts from exljbris Font Foundry"
 HOMEPAGE="http://www.josbuivenga.demon.nl/"
-SRC_URI="http://www.exljbris.com/dl/delicious-123.zip
+SRC_URI="
+       http://www.exljbris.com/dl/delicious-123.zip
        http://www.exljbris.com/dl/Diavlo_II_37b2.zip
        http://www.exljbris.com/dl/fontin2_pc.zip
        http://www.exljbris.com/dl/FontinSans_49.zip
@@ -16,20 +17,16 @@ SRC_URI="http://www.exljbris.com/dl/delicious-123.zip
 LICENSE="exljbris-free"
 SLOT="0"
 KEYWORDS="~amd64 ~x86"
-IUSE=""
-
 RESTRICT="mirror"
 
-DEPEND="app-arch/unzip"
-RDEPEND=""
+BDEPEND="app-arch/unzip"
 
 S="${WORKDIR}"
+
 FONT_S="${S}"
 FONT_SUFFIX="otf ttf"
 
-src_unpack() {
-       unpack ${A}
-       cd "${S}"
-
-       mv "${S}"/Diavlo_II_37/*.otf "${S}"
+src_prepare() {
+       default
+       mv Diavlo_II_37/*.otf . || die
 }