net-p2p/qbittorrent: sync live ebuild
authorMikle Kolyada <zlogene@gentoo.org>
Wed, 4 Mar 2020 13:33:26 +0000 (16:33 +0300)
committerMikle Kolyada <zlogene@gentoo.org>
Wed, 4 Mar 2020 13:34:07 +0000 (16:34 +0300)
Package-Manager: Portage-2.3.84, Repoman-2.3.20
Signed-off-by: Mikle Kolyada <zlogene@gentoo.org>
net-p2p/qbittorrent/qbittorrent-9999.ebuild

index 22b2a5ad4a479b18ff1d1c0a880c27f4ae473db5..7813f67cbfa8f0de0470618f6c1adde68c754d4a 100644 (file)
@@ -1,9 +1,9 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=7
 
-inherit gnome2-utils xdg-utils
+inherit xdg-utils
 
 DESCRIPTION="BitTorrent client in C++ and Qt"
 HOMEPAGE="https://www.qbittorrent.org
@@ -14,7 +14,7 @@ if [[ ${PV} == *9999 ]]; then
        EGIT_REPO_URI="https://github.com/${PN}/qBittorrent.git"
 else
        SRC_URI="https://github.com/qbittorrent/qBittorrent/archive/release-${PV}.tar.gz -> ${P}.tar.gz"
-       KEYWORDS="~amd64 ~arm ~ppc64 ~x86"
+       KEYWORDS="amd64 ~arm ~ppc64 x86"
        S="${WORKDIR}/qBittorrent-release-${PV}"
 fi
 
@@ -59,11 +59,11 @@ src_install() {
 }
 
 pkg_postinst() {
-       gnome2_icon_cache_update
+       xdg_icon_cache_update
        xdg_desktop_database_update
 }
 
 pkg_postrm() {
-       gnome2_icon_cache_update
+       xdg_icon_cache_update
        xdg_desktop_database_update
 }