dev-db/myodbc: bump to v8.0.20
authorThomas Deutschmann <whissi@gentoo.org>
Sat, 23 May 2020 20:53:10 +0000 (22:53 +0200)
committerThomas Deutschmann <whissi@gentoo.org>
Sat, 23 May 2020 20:53:10 +0000 (22:53 +0200)
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
dev-db/myodbc/Manifest
dev-db/myodbc/myodbc-8.0.20.ebuild [new file with mode: 0644]

index 0be45e21dbe4a68095d40f40123a8e7ec5b085e3..b08ad26d298005caa44cae6c99c06752052ebc8e 100644 (file)
@@ -4,3 +4,4 @@ DIST mysql-connector-odbc-5.3.9-linux-debian9-x86-64bit.tar.gz 12013057 BLAKE2B
 DIST mysql-connector-odbc-8.0.16-src.tar.gz 3986610 BLAKE2B c91760f8e0352a57adb5400700d22f52f70d5210d85ff0932f5288f19c917c771ce9ea9abad097d27a9723c585d1029d56c09f6865f634f9c41ad852690e016d SHA512 b7ddcdf635441bc3ed0325a8562f453e42d3c9768b0fe0b42d9b5417e268f4631e3fca3c2adc417c124ede37254c7b1890c792593d846ecaf5b158ce4b4808cd
 DIST mysql-connector-odbc-8.0.17-src.tar.gz 3953949 BLAKE2B 6d7fcef89c15d9f421f690291e793f1020b5f77f5e2132f130becd1ceed041887ffce77fda4cbc411d06972f1d488d434c8f132c0778af30a436c6b6e372e59e SHA512 474b107eb5d4c23e10c24dcf37b3787418afbd34ea385791fd0d8cdb5d29a6770cde4a61e3591329b344c442ff8f6daad3a2c250e881f9f5837eaa4e951af7e4
 DIST mysql-connector-odbc-8.0.19-src.tar.gz 3770465 BLAKE2B 7c57d85c13c17c08e1aed1deff3d60851ff68474c42971ea796fc50e3b766d7c49e5d993527691534c30f4007a94be852ac240bf50244cd3adf0f9500fbfc68c SHA512 4761d9d3eeccc932bfd76b9b27be4672e65b6125e85312dcfcb0b8b3cfe0ccf19982d40b2f85ae26e936e968d35d3136bab201b7dcb47eb4ad460c178c0d9f88
+DIST mysql-connector-odbc-8.0.20-src.tar.gz 3734268 BLAKE2B 606e8fe88712371da74bee8f44b21a56a2572603b1af693733fdd9ccd7ab62cb16a224593b368a40a021ed87ee433213a1a03b775c07b6bd28bbc44b7f905288 SHA512 483eb5c1d4a75ec4ec8681b33633bf89db708737191d149e1fed3c8bf0f839ab70951982a664fbf078c73fdfc114b126b5146682238faa244c904becf80858d7
diff --git a/dev-db/myodbc/myodbc-8.0.20.ebuild b/dev-db/myodbc/myodbc-8.0.20.ebuild
new file mode 100644 (file)
index 0000000..4577fec
--- /dev/null
@@ -0,0 +1,118 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake-multilib
+
+MAJOR="$(ver_cut 1-2)"
+MY_PN="mysql-connector-odbc"
+MY_P="${MY_PN}-${PV/_p/r}-src"
+
+DESCRIPTION="ODBC driver for MySQL"
+HOMEPAGE="https://dev.mysql.com/downloads/connector/odbc/"
+SRC_URI="https://dev.mysql.com/get/Downloads/Connector-ODBC/${MAJOR}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="${MAJOR}"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+# Broken when built dynamically against libmysqlclient.so
+RDEPEND="
+       dev-db/unixODBC[${MULTILIB_USEDEP}]
+       >=dev-db/mysql-connector-c-8.0:0=[static-libs,${MULTILIB_USEDEP}]
+"
+DEPEND="${RDEPEND}"
+S=${WORKDIR}/${MY_P}
+
+# Careful!
+DRIVER_NAME="${PN}-${SLOT}"
+
+# Patch document path so it doesn't install files to /usr
+PATCHES=(
+       "${FILESDIR}/${MAJOR}-cmake-doc-path.patch"
+       "${FILESDIR}/${PN}-8.0.19-cxxlinkage.patch"
+)
+
+src_prepare() {
+       # Remove Tests
+       sed -i -e "s/ADD_SUBDIRECTORY(test)//" \
+               "${S}/CMakeLists.txt"
+
+       cmake-utils_src_prepare
+}
+
+multilib_src_configure() {
+       mycmakeargs+=(
+               -DMYSQLCLIENT_STATIC_LINKING=1
+               -DMYSQL_CXX_LINKAGE=1
+               -DWITH_UNIXODBC=1
+               -DWITH_DOCUMENTATION_INSTALL_PATH=/usr/share/doc/${PF}
+               -DLIB_SUBDIR="$(get_libdir)/${PN}-${MAJOR}"
+               -DMYSQLCLIENT_NO_THREADS=ON
+               -DDISABLE_GUI=ON
+               # The NUMA and LIBWRAP options are not really used.
+               # They are just copied from the server code
+               -DWITH_NUMA=OFF
+               -DWITH_LIBWRAP=OFF
+       )
+       cmake-utils_src_configure
+}
+
+multilib_src_install_all() {
+       debug-print-function ${FUNCNAME} "$@"
+
+       dodir /usr/share/${PN}-${SLOT}
+       for i in odbc.ini odbcinst.ini; do
+               einfo "Building $i"
+                       sed \
+                       -e "s,__PN__,${DRIVER_NAME},g" \
+                       -e "s,__PF__,${MAJOR},g" \
+                       -e "s,lib/libmyodbc3.so,$(get_libdir)/${PN}-${MAJOR}/libmyodbc${SLOT:0:1}a.so,g" \
+                       >"${D}"/usr/share/${PN}-${SLOT}/${i} \
+                       <"${FILESDIR}"/${i}.m4 \
+                       || die "Failed to build $i"
+       done;
+       mv "${D}/usr/bin/myodbc-installer" \
+               "${D}/usr/bin/myodbc-installer-${MAJOR}" || die "failed to move slotted binary"
+}
+
+pkg_config() {
+
+       [ "${ROOT}" != "/" ] && \
+               die 'Sorry, non-standard ROOT setting is not supported :-('
+
+       local msg='MySQL ODBC driver'
+       local drivers=$(/usr/bin/odbcinst -q -d)
+
+       if echo $drivers | grep -vq "^\[${DRIVER_NAME}\]$" ; then
+               ebegin "Installing ${msg}"
+               /usr/bin/odbcinst -i -d -f /usr/share/${PN}-${SLOT}/odbcinst.ini
+               rc=$?
+               eend $rc
+               [ $rc -ne 0 ] && die
+       else
+               einfo "Skipping already installed ${msg}"
+       fi
+
+       local sources=$(/usr/bin/odbcinst -q -s)
+       msg='sample MySQL ODBC DSN'
+       if echo $sources | grep -vq "^\[${DRIVER_NAME}-test\]$"; then
+               ebegin "Installing ${msg}"
+               /usr/bin/odbcinst -i -s -l -f /usr/share/${PN}-${SLOT}/odbc.ini
+               rc=$?
+               eend $rc
+               [ $rc -ne 0 ] && die
+       else
+               einfo "Skipping already installed ${msg}"
+       fi
+}
+
+pkg_postinst() {
+       elog "If this is a new install, please run the following command"
+       elog "to configure the MySQL ODBC drivers and sources:"
+       elog "emerge --config =${CATEGORY}/${PF}"
+       elog "Please note that the driver name used to form the DSN now includes the SLOT."
+       elog "The myodbc-install utility is installed as myodbc-install-${MAJOR}"
+}