dev-python/logbook: version bump to 1.5.3
authorAndreas Zuber <a.zuber@gmx.ch>
Fri, 24 Apr 2020 09:06:07 +0000 (11:06 +0200)
committerMichał Górny <mgorny@gentoo.org>
Mon, 27 Apr 2020 08:33:02 +0000 (10:33 +0200)
Closes: https://bugs.gentoo.org/707804
Closes: https://bugs.gentoo.org/719082
Package-Manager: Portage-2.3.89, Repoman-2.3.20
Signed-off-by: Andreas Zuber <a.zuber@gmx.ch>
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/logbook/Manifest
dev-python/logbook/logbook-1.5.3.ebuild [new file with mode: 0644]

index d86e773ed3a7f0e244c64c18c1f700775f08f4df..94237f0d672643d7831e18e6b9ffa974505201b3 100644 (file)
@@ -1 +1,2 @@
 DIST logbook-1.4.0.tar.gz 369335 BLAKE2B 02398be49d2a12aadbcde90561afe6ac08060877922fa04b27f08587115aef8faf47bfc352fc005b8a986ab619289c8544fe53a84e0e863a09c992685f78739c SHA512 3ea969e9e2075e34a915566be906266b408671657e4cecbe47663c28f2212c0522b0f0eb2832fbc4fb906f70c8e53d3cdbe65923dafe53a77545b8126ab539f2
+DIST logbook-1.5.3.tar.gz 371901 BLAKE2B e37924e06613ccf27380004b159966b7b42ec7b766afb6904751eafb3d774c5a9994b9d63f834fbe949fe345953c0da4693e093d717b589046412bd4056322bf SHA512 c9068324f12a189ced98e2c02753489847fa533ce3a3af07b62c73e9959c2e014d47515d47e756d031639cb220a2c4a9a380cba4cb3ea1b190c50106decba686
diff --git a/dev-python/logbook/logbook-1.5.3.ebuild b/dev-python/logbook/logbook-1.5.3.ebuild
new file mode 100644 (file)
index 0000000..6101303
--- /dev/null
@@ -0,0 +1,44 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="A logging replacement for Python"
+HOMEPAGE="https://logbook.readthedocs.io/en/stable/
+       https://github.com/getlogbook/logbook
+       https://pypi.org/project/Logbook/"
+SRC_URI="https://github.com/getlogbook/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+BDEPEND="
+       test? (
+               app-arch/brotli[${PYTHON_USEDEP},python]
+               dev-python/execnet[${PYTHON_USEDEP}]
+               dev-python/jinja[${PYTHON_USEDEP}]
+               dev-python/pyzmq[${PYTHON_USEDEP}]
+               dev-python/sqlalchemy[${PYTHON_USEDEP}]
+       )"
+RDEPEND="
+       !!dev-python/contextvars
+       !!dev-python/gevent"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs
+
+python_prepare_all() {
+       # Delete test file requiring local connection to redis server
+       rm tests/test_queues.py || die
+       distutils-r1_python_prepare_all
+}
+
+python_configure_all() {
+       export DISABLE_LOGBOOK_CEXT=1
+}