x11-misc/xdotool: Drop old
authorHarri Nieminen <moikkis@gmail.com>
Mon, 6 Feb 2017 09:04:50 +0000 (11:04 +0200)
committerMichael Palimaka <kensington@gentoo.org>
Mon, 6 Feb 2017 10:11:52 +0000 (21:11 +1100)
Package-Manager: Portage-2.3.3, Repoman-2.3.1

x11-misc/xdotool/xdotool-3.20150503.1.ebuild [deleted file]

diff --git a/x11-misc/xdotool/xdotool-3.20150503.1.ebuild b/x11-misc/xdotool/xdotool-3.20150503.1.ebuild
deleted file mode 100644 (file)
index 247db09..0000000
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=2
-
-inherit eutils toolchain-funcs flag-o-matic multilib
-
-DESCRIPTION="Simulate keyboard input and mouse activity, move and resize windows"
-HOMEPAGE="http://www.semicomplete.com/projects/xdotool/"
-SRC_URI="https://github.com/jordansissel/xdotool/releases/download/v${PV}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~ppc ~x86"
-IUSE="examples"
-
-RDEPEND="x11-libs/libXtst
-       x11-libs/libX11
-       x11-libs/libXinerama
-       x11-libs/libxkbcommon"
-DEPEND="${RDEPEND}"
-
-# The test wants to manualy start Xvfb, wont use VirtualX and it tries
-# to run a full gnome-session. For such a tiny application i consider
-# it overkill to rewrite the test scripts to not use it's own X server
-# and add a full blown gnome just to run the tests.
-RESTRICT="test"
-
-src_prepare() {
-       sed -i \
-               -e "s/installheader post-install$/installheader/" \
-               -e 's:\<pkg-config\>:$(PKG_CONFIG):' \
-               Makefile || die "sed failed"
-}
-
-src_compile() {
-       tc-export CC LD PKG_CONFIG
-       default
-}
-
-src_install() {
-       emake PREFIX="${D}usr" INSTALLMAN="${D}usr/share/man" INSTALLLIB="${D}usr/$(get_libdir)" install || die
-
-       dodoc CHANGELIST README
-       if use examples; then
-               insinto /usr/share/doc/${PF}/examples
-               doins examples/*
-       fi
-}