app-crypt/libb2: initial version, ebuild by me
authorFabian Groffen <grobian@gentoo.org>
Mon, 27 Nov 2017 12:02:08 +0000 (13:02 +0100)
committerFabian Groffen <grobian@gentoo.org>
Mon, 27 Nov 2017 12:02:31 +0000 (13:02 +0100)
Package-Manager: Portage-2.3.13, Repoman-2.3.3

app-crypt/libb2/Manifest [new file with mode: 0644]
app-crypt/libb2/libb2-0.98.ebuild [new file with mode: 0644]
app-crypt/libb2/metadata.xml [new file with mode: 0644]

diff --git a/app-crypt/libb2/Manifest b/app-crypt/libb2/Manifest
new file mode 100644 (file)
index 0000000..44054d6
--- /dev/null
@@ -0,0 +1 @@
+DIST libb2-0.98.tar.gz 275076 BLAKE2B 7c0aa473a58a5ceb6e913487cc6f0078e6cab661bd26cb1f5611473b430213521a23adbde227da6d7561b4d581369e268308ae6b2a10da5399c0d2d6ab288b26 SHA512 be400d16ab00b3006ec7412dcbf580427600f4997cee19c0448d849ff8bbbb58bbb7be3d49e4052cb1b6791b6bed9c9cc48b51da3ec77b2fdf3d197ccf0c8073
diff --git a/app-crypt/libb2/libb2-0.98.ebuild b/app-crypt/libb2/libb2-0.98.ebuild
new file mode 100644 (file)
index 0000000..08bf237
--- /dev/null
@@ -0,0 +1,42 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools ltprune
+
+DESCRIPTION="C library providing BLAKE2b, BLAKE2s, BLAKE2bp, BLAKE2sp"
+HOMEPAGE="https://github.com/BLAKE2/libb2"
+GITHASH="0d7015f6a640a63bc6c68562328e112445ea9d5c"
+SRC_URI="https://github.com/BLAKE2/libb2/archive/${GITHASH}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="CC0-1.0"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64"
+IUSE="static"
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${PN}-${GITHASH}
+
+src_prepare() {
+       default
+       # fix bashism
+       sed -i -e 's/ == / = /' configure.ac || die
+       eautoreconf  # upstream doesn't make releases
+}
+
+src_configure() {
+       econf $(use_enable static)
+}
+
+src_compile() {
+       # respect our CFLAGS
+       emake CFLAGS="${CFLAGS}"
+}
+
+src_install() {
+       default
+       prune_libtool_files
+}
diff --git a/app-crypt/libb2/metadata.xml b/app-crypt/libb2/metadata.xml
new file mode 100644 (file)
index 0000000..5ef83e9
--- /dev/null
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+       <maintainer type="person">
+               <email>grobian@gentoo.org</email>
+               <name>Fabian Groffen</name>
+       </maintainer>
+       <longdescription lang="en">
+               C library providing BLAKE2b, BLAKE2s, BLAKE2bp, BLAKE2sp
+
+               Official implementations from BLAKE2 project.
+       </longdescription>
+</pkgmetadata>