sys-devel/binutils-config: bump up to 5.3, bug #724454
authorSergei Trofimovich <slyfox@gentoo.org>
Fri, 22 May 2020 20:52:03 +0000 (21:52 +0100)
committerSergei Trofimovich <slyfox@gentoo.org>
Fri, 22 May 2020 20:53:03 +0000 (21:53 +0100)
Main change is USE=native-symlinks to avoid symlinks
without ${CTARGET} qualifier.

Bug: https://bugs.gentoo.org/724454
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
sys-devel/binutils-config/Manifest
sys-devel/binutils-config/binutils-config-5.3.ebuild [new file with mode: 0644]
sys-devel/binutils-config/binutils-config-9999.ebuild

index 5def3cddef8d6004d4a91d3b2080e724acb2ff03..f40e04ac4038584bb3efde8936a6f84b3dba4df5 100644 (file)
@@ -1 +1,2 @@
 DIST binutils-config-5.2.1.tar.xz 6200 BLAKE2B e9b5c61e17aeae8b537c485dd555424136d1638182bb92f22f66eac27e18997d45b1a34b1362622bdc21d060ffac8627e9072107561b81c12ee579a55ef40313 SHA512 9ae130da747eaca8ca9717a69be053eba33946fc4101b77fd795d18202e9d6c27f169c29568b5c97b8f581a37f317b72d13b6d61267a61b117e970f3cfbe048b
+DIST binutils-config-5.3.tar.xz 6572 BLAKE2B ae3593e8576419f00ea8f471c6c93dccb90e4e87e682a028d2f9c42608f4269533f7322be5153ee178f3af89ae2270ffc4334903613e803735c748f88699c66f SHA512 31253f6ba4b1fdbf71c251066fed3ab9bd351b67bd4b12c134a8ba1c258ef0b4a8c571c981e23ab4b5f5aa9175ce151024a19729b6edb7ec61ad08ec7c262b24
diff --git a/sys-devel/binutils-config/binutils-config-5.3.ebuild b/sys-devel/binutils-config/binutils-config-5.3.ebuild
new file mode 100644 (file)
index 0000000..5f9cd23
--- /dev/null
@@ -0,0 +1,43 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit prefix
+
+if [[ ${PV} == 9999 ]]; then
+       EGIT_REPO_URI="https://anongit.gentoo.org/git/proj/binutils-config.git"
+       inherit git-r3
+else
+       SRC_URI="https://dev.gentoo.org/~slyfox/distfiles/${P}.tar.xz"
+       KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+fi
+
+DESCRIPTION="Utility to change the binutils version being used"
+HOMEPAGE="https://wiki.gentoo.org/wiki/Project:Toolchain"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="+native-symlinks"
+
+# We also RDEPEND on sys-apps/findutils which is in base @system
+RDEPEND="sys-apps/gentoo-functions"
+
+src_compile() {
+       emake DESTDIR="${D}" PV="${PV}" USE_NATIVE_LINKS="$(usex native-symlinks)"
+}
+
+src_install() {
+       emake DESTDIR="${D}" PV="${PV}" install
+
+       use prefix && eprefixify "${ED}"/usr/bin/${PN}
+}
+
+pkg_postinst() {
+       # Re-register all targets. USE flags or new versions can change
+       # installed symlinks.
+       local x
+       for x in $(binutils-config -C -l 2>/dev/null | awk '$NF == "*" { print $2 }') ; do
+               binutils-config ${x}
+       done
+}
index d284d9330ece4649a15fe3baaa49c1770f86d524..5f9cd23da4a1aac2a856835142180fbd14c0066b 100644 (file)
@@ -10,7 +10,7 @@ if [[ ${PV} == 9999 ]]; then
        inherit git-r3
 else
        SRC_URI="https://dev.gentoo.org/~slyfox/distfiles/${P}.tar.xz"
-       KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
+       KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
 fi
 
 DESCRIPTION="Utility to change the binutils version being used"