x11-apps/xauth: Port to EAPI=7
authorMatt Turner <mattst88@gentoo.org>
Fri, 12 Jul 2019 05:57:58 +0000 (22:57 -0700)
committerMatt Turner <mattst88@gentoo.org>
Fri, 12 Jul 2019 05:59:22 +0000 (22:59 -0700)
Signed-off-by: Matt Turner <mattst88@gentoo.org>
x11-apps/xauth/xauth-9999.ebuild

index aa5cc700c6611f3344e98e6cb0a8b4ffeccf42d0..057d3ed2a71e98c511815d23653accc4929861f4 100644 (file)
@@ -1,13 +1,17 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=5
+EAPI=7
 
-inherit autotools-utils xorg-2
+inherit xorg-3
 
-DESCRIPTION="X authority file utility"
+if [[ ${PV} == 9999* ]]; then
+       SRC_URI=""
+else
+       KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x64-cygwin ~amd64-fbsd ~amd64-linux ~x86-linux"
+fi
 
-KEYWORDS=""
+DESCRIPTION="X authority file utility"
 IUSE="ipv6 test"
 
 RDEPEND="x11-libs/libX11
@@ -15,17 +19,16 @@ RDEPEND="x11-libs/libX11
        x11-libs/libXext
        x11-libs/libXmu"
 DEPEND="${RDEPEND}
-       test? ( dev-util/cmdtest )"
+       x11-base/xorg-proto"
+BDEPEND="test? ( dev-util/cmdtest )"
 
-src_configure() {
+pkg_setup() {
        XORG_CONFIGURE_OPTIONS=(
                $(use_enable ipv6)
        )
-       xorg-2_src_configure
 }
 
 src_test() {
-       # Address sandbox failure, bug #527574
        addwrite /proc/self/comm
-       autotools-utils_src_test
+       emake check
 }