app-text/xml2doc: Add patch for GCC 10
authorDavid Seifert <soap@gentoo.org>
Tue, 21 Jan 2020 21:51:01 +0000 (22:51 +0100)
committerDavid Seifert <soap@gentoo.org>
Tue, 21 Jan 2020 21:51:01 +0000 (22:51 +0100)
Package-Manager: Portage-2.3.84, Repoman-2.3.20
Signed-off-by: David Seifert <soap@gentoo.org>
app-text/xml2doc/files/xml2doc-20030510-gcc10-no-common.patch [new file with mode: 0644]
app-text/xml2doc/xml2doc-20030510-r1.ebuild

diff --git a/app-text/xml2doc/files/xml2doc-20030510-gcc10-no-common.patch b/app-text/xml2doc/files/xml2doc-20030510-gcc10-no-common.patch
new file mode 100644 (file)
index 0000000..17965c9
--- /dev/null
@@ -0,0 +1,18 @@
+--- a/src/defs.h
++++ b/src/defs.h
+@@ -18,13 +18,13 @@
+ /* Global vars */
+-enum
++enum align
+ {
+       ALIGN_RIGHT,
+       ALIGN_LEFT,
+       ALIGN_JUSTIFY,
+       ALIGN_CENTER
+-} align;
++};
+ typedef struct 
+ {
index 3c962351552f6b437cac60f73e235f6cc0fa4301..e4a387e503a4d4ec1a84ccd26fb4d098f22113b0 100644 (file)
@@ -23,6 +23,8 @@ PATCHES=(
        "${FILESDIR}"/${PN}-pointer_fix.patch
        # Don't strip symbols from binary (bug #152266)
        "${FILESDIR}"/${P}-makefile.patch
+       # fix GCC 10 -fno-common change
+       "${FILESDIR}"/${P}-gcc10-no-common.patch
 )
 
 src_configure() {