dev-ruby/pluggaloid: add 1.1.2
authorHans de Graaff <graaff@gentoo.org>
Thu, 2 May 2019 05:56:54 +0000 (07:56 +0200)
committerHans de Graaff <graaff@gentoo.org>
Thu, 2 May 2019 06:36:43 +0000 (08:36 +0200)
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Package-Manager: Portage-2.3.62, Repoman-2.3.11

dev-ruby/pluggaloid/Manifest
dev-ruby/pluggaloid/pluggaloid-1.1.2.ebuild [new file with mode: 0644]

index d8c90a1adfe39d31f630e5c1cedaf515c89eef5f..5a972540cbfcd8c2b26c4b03464dcc39cf06a799 100644 (file)
@@ -1 +1,2 @@
 DIST pluggaloid-1.1.1.gem 14336 BLAKE2B c4191a02630d764985546ec40520e09a8aef6e1b5bc94da5e5f058065ef7f6a18751dad10d293c3219f1eca21e17b310b1998e33c4e96573f33dd28faa50bb6c SHA512 80453954f98c7fba354455b73538d055a7d9d38e38f16723dcc4b04811286a8e34e413f31d988b86580eb5a4890d5405c78e6798bcf1ca489fd3159b23653070
+DIST pluggaloid-1.1.2.gem 14848 BLAKE2B 72bbcfe71c3c2e6a96425639b0db2af9a10f92888af09093861879529458e51ef3793a614a8d573829a4cc34be6e56721bd3f01523f3e5feb722800538ed097c SHA512 e381adf34e918c7d9e1b1ca88cc7eba585f2d88937fc7e2fbb6ffc7e276ecea42f27e101bb0d0a80ce5d365cdbaca9aab0c8f2ba33899cc3e1ba6729514de1da
diff --git a/dev-ruby/pluggaloid/pluggaloid-1.1.2.ebuild b/dev-ruby/pluggaloid/pluggaloid-1.1.2.ebuild
new file mode 100644 (file)
index 0000000..56d0bd4
--- /dev/null
@@ -0,0 +1,27 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+USE_RUBY="ruby24 ruby25 ruby26"
+
+RUBY_FAKEGEM_RECIPE_DOC="doc"
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit ruby-fakegem
+DESCRIPTION="Pluggaloid is extensible plugin system for mikutter"
+HOMEPAGE="https://rubygems.org/gems/pluggaloid/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+ruby_add_rdepend "
+       dev-ruby/delayer
+       dev-ruby/instance_storage:0
+"
+
+all_ruby_prepare() {
+       sed -i -e '/bundler/ s:^:#:' Rakefile test/*_test.rb || die
+}