www-client/firefox: block USE=pgo when USE=-clang
authorThomas Deutschmann <whissi@gentoo.org>
Mon, 24 Feb 2020 22:31:24 +0000 (23:31 +0100)
committerThomas Deutschmann <whissi@gentoo.org>
Mon, 24 Feb 2020 22:35:18 +0000 (23:35 +0100)
USE=pgo is currently known to be broken when using GCC.

Instead of silently ignoring USE=pgo when using GCC, we are
forcing a user decision so user has the chance to enable USE=clang
in case PGO is important for user without wasting 2+ hours
commpiling firefox just to find out that PGO which was requested
was ignored.

Bug: https://bugs.gentoo.org/709594
Bug: https://bugs.gentoo.org/709654
Package-Manager: Portage-2.3.89, Repoman-2.3.20
Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
www-client/firefox/firefox-73.0.1.ebuild

index a9232b0afb238071d33447214779d63a85e158c8..106e5b996ea3eeea1140b2d2c6d83f5aba71b28d 100644 (file)
@@ -209,6 +209,14 @@ pkg_pretend() {
                if ! has usersandbox $FEATURES ; then
                        die "You must enable usersandbox as X server can not run as root!"
                fi
+
+               if ! use clang ; then
+                       # Force user decision so they don't find out firefox was build
+                       # without pgo after spending some hours
+                       eerror "USE=pgo when using GCC is currently known to be broken."
+                       eerror "Either switch to USE=clang or temporarily set USE=-pgo."
+                       die "USE=pgo without USE=clang is currently known to be broken."
+               fi
        fi
 
        # Ensure we have enough disk space to compile