Define portage.const.VCS_DIRS and use it in some modules.
authorArfrever Frehtes Taifersar Arahesis <Arfrever@Apache.Org>
Wed, 13 Mar 2013 03:43:15 +0000 (04:43 +0100)
committerArfrever Frehtes Taifersar Arahesis <Arfrever@Apache.Org>
Wed, 13 Mar 2013 03:43:15 +0000 (04:43 +0100)
pym/_emerge/actions.py
pym/_emerge/depgraph.py
pym/portage/const.py
pym/portage/manifest.py
pym/portage/update.py
pym/portage/util/__init__.py
pym/portage/util/listdir.py

index fae293ee288d2692f528e5625e0a348fa0d3248a..7fe8e838833bda1a496822f58274a716dca70f8b 100644 (file)
@@ -37,8 +37,7 @@ from portage import os
 from portage import shutil
 from portage import eapi_is_supported, _encodings, _unicode_decode
 from portage.cache.cache_errors import CacheError
-from portage.const import GLOBAL_CONFIG_PATH
-from portage.const import _DEPCLEAN_LIB_CHECK_DEFAULT
+from portage.const import GLOBAL_CONFIG_PATH, VCS_DIRS, _DEPCLEAN_LIB_CHECK_DEFAULT
 from portage.dbapi.dep_expand import dep_expand
 from portage.dbapi._expand_new_virt import expand_new_virt
 from portage.dep import Atom
@@ -2083,7 +2082,7 @@ def action_sync(settings, trees, mtimedb, myopts, myaction):
                        noiselevel=-1, level=logging.ERROR)
                return 1
 
-       vcs_dirs = frozenset([".git", ".svn", "CVS", ".hg"])
+       vcs_dirs = frozenset(VCS_DIRS)
        vcs_dirs = vcs_dirs.intersection(os.listdir(myportdir))
 
        os.umask(0o022)
index 34ad41353c663ea10d5008c80c7a64d3650137ff..965d3bceff7bc4fb54240dcf9c9a051fd702ea69 100644 (file)
@@ -15,7 +15,7 @@ from itertools import chain
 import portage
 from portage import os, OrderedDict
 from portage import _unicode_decode, _unicode_encode, _encodings
-from portage.const import PORTAGE_PACKAGE_ATOM, USER_CONFIG_PATH
+from portage.const import PORTAGE_PACKAGE_ATOM, USER_CONFIG_PATH, VCS_DIRS
 from portage.dbapi import dbapi
 from portage.dbapi.dep_expand import dep_expand
 from portage.dbapi._similar_name_search import similar_name_search
@@ -40,7 +40,6 @@ from portage.util import cmp_sort_key, writemsg, writemsg_stdout
 from portage.util import ensure_dirs
 from portage.util import writemsg_level, write_atomic
 from portage.util.digraph import digraph
-from portage.util.listdir import _ignorecvs_dirs
 from portage.util._async.TaskScheduler import TaskScheduler
 from portage.versions import catpkgsplit
 
@@ -6822,7 +6821,7 @@ class depgraph(object):
                                        if stat.S_ISREG(st.st_mode):
                                                last_file_path = p
                                        elif stat.S_ISDIR(st.st_mode):
-                                               if os.path.basename(p) in _ignorecvs_dirs:
+                                               if os.path.basename(p) in VCS_DIRS:
                                                        continue
                                                try:
                                                        contents = os.listdir(p)
index 3859a1666c91edc9de233346c9e67c78da4b8b44..fdd33e63c3ac019d3320356056b186ebb51af56e 100644 (file)
@@ -163,6 +163,8 @@ if "PORTAGE_OVERRIDE_EPREFIX" in os.environ:
        if EPREFIX:
                EPREFIX = os.path.normpath(EPREFIX)
 
+VCS_DIRS = ("CVS", "RCS", "SCCS", ".bzr", ".git", ".hg", ".svn")
+
 # ===========================================================================
 # END OF CONSTANTS -- END OF CONSTANTS -- END OF CONSTANTS -- END OF CONSTANT
 # ===========================================================================
index 513f1ca8f18efa463073e584b50ac0a3abde8899..5b4082686a1f881a89c65deab2b1a609a2e66e4e 100644 (file)
@@ -25,7 +25,8 @@ from portage.exception import DigestException, FileNotFound, \
        InvalidDataType, MissingParameter, PermissionDenied, \
        PortageException, PortagePackageException
 from portage.const import (MANIFEST1_HASH_FUNCTIONS, MANIFEST2_HASH_DEFAULTS,
-       MANIFEST2_HASH_FUNCTIONS, MANIFEST2_IDENTIFIERS, MANIFEST2_REQUIRED_HASH)
+       MANIFEST2_HASH_FUNCTIONS, MANIFEST2_IDENTIFIERS, MANIFEST2_REQUIRED_HASH,
+       VCS_DIRS)
 from portage.localization import _
 
 _manifest_re = re.compile(
@@ -53,7 +54,7 @@ def manifest2AuxfileFilter(filename):
 
 def manifest2MiscfileFilter(filename):
        filename = filename.strip(os.sep)
-       return not (filename in ["CVS", ".svn", "files", "Manifest"] or filename.endswith(".ebuild"))
+       return not (filename in VCS_DIRS + ("files", "Manifest") or filename.endswith(".ebuild"))
 
 def guessManifestFileType(filename):
        """ Perform a best effort guess of which type the given filename is, avoid using this if possible """
index f518510c4d79c73383201152423a23e26e7fa308..1b45a7aaf4275252207bc4aa201b7b766eec3249 100644 (file)
@@ -19,10 +19,9 @@ portage.proxy.lazyimport.lazyimport(globals(),
        'portage.dep:Atom,dep_getkey,isvalidatom,_get_slot_re',
        'portage.util:ConfigProtect,new_protect_filename,' + \
                'normalize_path,write_atomic,writemsg',
-       'portage.util.listdir:_ignorecvs_dirs',
 )
 
-from portage.const import USER_CONFIG_PATH
+from portage.const import USER_CONFIG_PATH, VCS_DIRS
 from portage.dep import match_from_list
 from portage.eapi import _get_eapi_attrs
 from portage.exception import DirectoryNotFound, InvalidAtom, PortageException
@@ -327,7 +326,7 @@ def update_config_files(config_root, protect, protect_mask, update_iter, match_c
                                        except UnicodeDecodeError:
                                                dirs.remove(y_enc)
                                                continue
-                                       if y.startswith(".") or y in _ignorecvs_dirs:
+                                       if y.startswith(".") or y in VCS_DIRS:
                                                dirs.remove(y_enc)
                                for y in files:
                                        try:
index da5277bff7245d28fa1660872104ee84b892d36d..5085a8bb923c1e5d276c6eb626091098061f5212 100644 (file)
@@ -31,7 +31,6 @@ import portage
 portage.proxy.lazyimport.lazyimport(globals(),
        'pickle',
        'portage.dep:Atom',
-       'portage.util.listdir:_ignorecvs_dirs',
        'subprocess',
 )
 
@@ -40,6 +39,7 @@ from portage import _encodings
 from portage import _os_merge
 from portage import _unicode_encode
 from portage import _unicode_decode
+from portage.const import VCS_DIRS
 from portage.exception import InvalidAtom, PortageException, FileNotFound, \
        OperationNotPermitted, ParseError, PermissionDenied, ReadOnlyFileSystem
 from portage.localization import _
@@ -480,7 +480,7 @@ def grabfile_package(myfilename, compatlevel=0, recursive=0, allow_wildcard=Fals
 def grablines(myfilename, recursive=0, remember_source_file=False):
        mylines=[]
        if recursive and os.path.isdir(myfilename):
-               if os.path.basename(myfilename) in _ignorecvs_dirs:
+               if os.path.basename(myfilename) in VCS_DIRS:
                        return mylines
                try:
                        dirlist = os.listdir(myfilename)
index c2628cbfe510a7441da7f7fb6d4be9691bfe637d..b78ed19fec45ad0ad030efe4c04c4fa55dc1cee1 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 2010-2011 Gentoo Foundation
+# Copyright 2010-2013 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 
 __all__ = ['cacheddir', 'listdir']
@@ -8,10 +8,10 @@ import stat
 import time
 
 from portage import os
+from portage.const import VCS_DIRS
 from portage.exception import DirectoryNotFound, PermissionDenied, PortageException
 from portage.util import normalize_path, writemsg
 
-_ignorecvs_dirs = ('CVS', 'RCS', 'SCCS', '.svn', '.git')
 dircache = {}
 cacheHit = 0
 cacheMiss = 0
@@ -77,7 +77,7 @@ def cacheddir(my_original_path, ignorecvs, ignorelist, EmptyOnError, followSymli
                        pass
                elif ignorecvs:
                        if list[x][:2] != ".#" and \
-                               not (ftype[x] == 1 and list[x] in _ignorecvs_dirs):
+                               not (ftype[x] == 1 and list[x] in VCS_DIRS):
                                ret_list.append(list[x])
                                ret_ftype.append(ftype[x])
                else:
@@ -98,7 +98,7 @@ def listdir(mypath, recursive=False, filesonly=False, ignorecvs=False, ignorelis
        @type recursive: Boolean
        @param filesonly; Only return files, not more directories
        @type filesonly: Boolean
-       @param ignorecvs: Ignore CVS directories ('CVS','SCCS','.svn','.git')
+       @param ignorecvs: Ignore VCS directories
        @type ignorecvs: Boolean
        @param ignorelist: List of filenames/directories to exclude
        @type ignorelist: List