dev-libs/dietlibc: use tc-enables-pie instead of gcc-specs-pie
authorMatthias Maier <tamiko@gentoo.org>
Fri, 16 Jun 2017 22:24:24 +0000 (17:24 -0500)
committerMatthias Maier <tamiko@gentoo.org>
Fri, 16 Jun 2017 22:32:03 +0000 (17:32 -0500)
Package-Manager: Portage-2.3.6, Repoman-2.3.2

dev-libs/dietlibc/dietlibc-0.33_pre20110403.ebuild
dev-libs/dietlibc/dietlibc-0.34_pre20140729.ebuild

index 1fd0e978af7ed47144f277517ac745786ef077d9..62b7fabdd9c0ab68e01a43621340b7b02507952b 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI="3"
@@ -41,7 +41,7 @@ pkg_setup() {
                -Wno-unused -Wredundant-decls -fno-strict-aliasing
 
        # only use -nopie on archs that support it
-       gcc-specs-pie && append-flags -nopie
+       tc-enables-pie && append-flags -nopie
 }
 
 src_compile() {
index 399e1e780b956064b2f4c91a7ef01af84c124612..c35bb403afe46d8fe999a9e064f6a16ca71e9ee1 100644 (file)
@@ -36,7 +36,7 @@ src_prepare() {
        append-flags $(test-flags -fno-stack-protector)
 
        # only use -nopie on archs that support it
-       gcc-specs-pie && append-flags -nopie
+       tc-enables-pie && append-flags -nopie
 
        sed -i -e 's:strip::' Makefile || die
        append-flags -Wa,--noexecstack