dev-tcltk/tkimg: fix DeprecatedInsinto
authorTupone Alfredo <tupone@gentoo.org>
Sun, 15 Dec 2019 20:11:13 +0000 (21:11 +0100)
committerTupone Alfredo <tupone@gentoo.org>
Sun, 15 Dec 2019 20:11:13 +0000 (21:11 +0100)
Package-Manager: Portage-2.3.79, Repoman-2.3.16
Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
dev-tcltk/tkimg/tkimg-1.4.7.ebuild
dev-tcltk/tkimg/tkimg-1.4.9.ebuild

index 20537261f03a988b03cd2c85d1671deb978638a7..7b359e02e9fb69754b2c0895fc6a19b7e7f04943 100644 (file)
@@ -81,9 +81,9 @@ src_install() {
        dodoc ChangeLog README Reorganization.Notes.txt changes ANNOUNCE
 
        if use doc; then
-               insinto /usr/share/doc/${PF}
-               doins demo.tcl
-               insinto /usr/share/doc/${PF}/html
-               doins -r doc/*
+               docompress -x usr/share/doc/${PF}/demo.tcl
+               dodoc demo.tcl
+               docinto html
+               dodoc -r doc/*
        fi
 }
index 2746c0ba15ec170e1f97a0629517fec8c5be5166..e4eace19f9a3ce78218c453463c875cc809f197b 100644 (file)
@@ -1,7 +1,7 @@
 # Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=6
+EAPI=7
 
 inherit autotools eutils multilib prefix toolchain-funcs virtualx
 
@@ -94,9 +94,9 @@ src_install() {
        dodoc ChangeLog README Reorganization.Notes.txt changes ANNOUNCE
 
        if use doc; then
-               insinto /usr/share/doc/${PF}
-               doins demo.tcl
-               insinto /usr/share/doc/${PF}/html
-               doins -r doc/*
+               docompress -x usr/share/doc/${PF}/demo.tcl
+               dodoc demo.tcl
+               docinto html
+               dodoc -r doc/*
        fi
 }