app-arch/mt-st: Update live ebuild
authorJeroen Roovers <jer@gentoo.org>
Sun, 15 Dec 2019 11:14:24 +0000 (12:14 +0100)
committerJeroen Roovers <jer@gentoo.org>
Sun, 15 Dec 2019 11:14:51 +0000 (12:14 +0100)
Package-Manager: Portage-2.3.81, Repoman-2.3.20
Signed-off-by: Jeroen Roovers <jer@gentoo.org>
app-arch/mt-st/mt-st-9999.ebuild

index 0ec674f2d8b330823a58b3f0022e5ff89a0fcf8c..6201e07af2791dbe5ca9620797250330df2a9f8c 100644 (file)
@@ -1,19 +1,19 @@
 # Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI="6"
-inherit eutils git-r3 toolchain-funcs
+EAPI=7
+inherit git-r3 toolchain-funcs
 
 DESCRIPTION="control magnetic tape drive operation"
 HOMEPAGE="https://github.com/iustin/mt-st"
-EGIT_REPO_URI="https://github.com/iustin/mt-st.git"
+EGIT_REPO_URI="https://github.com/iustin/mt-st"
 
 LICENSE="GPL-2"
 SLOT="0"
 KEYWORDS=""
 
-src_compile() {
-       emake CC="$(tc-getCC)" CFLAGS="${CFLAGS} ${LDFLAGS}"
+src_configure() {
+       tc-export CC
 }
 
 src_install() {