dev-ros/audio_play: Initial import. Ebuild by me.
authorAlexis Ballier <aballier@gentoo.org>
Mon, 28 Sep 2015 13:01:26 +0000 (15:01 +0200)
committerAlexis Ballier <aballier@gentoo.org>
Mon, 28 Sep 2015 13:01:26 +0000 (15:01 +0200)
Package-Manager: portage-2.2.22

dev-ros/audio_play/Manifest [new file with mode: 0644]
dev-ros/audio_play/audio_play-0.2.7.ebuild [new file with mode: 0644]
dev-ros/audio_play/audio_play-9999.ebuild [new file with mode: 0644]
dev-ros/audio_play/metadata.xml [new file with mode: 0644]

diff --git a/dev-ros/audio_play/Manifest b/dev-ros/audio_play/Manifest
new file mode 100644 (file)
index 0000000..aec3da0
--- /dev/null
@@ -0,0 +1 @@
+DIST audio_common-0.2.7.tar.gz 173982 SHA256 bdffab26cd837b6db65d275dd14de143d1cf056167fc121b213b7403142195c4 SHA512 f765422bdb641e87132e1c9c56ca742d6830fed1d7414b337b61aa242f9955e4138ab13ee4a7786c78ff73f5824748ceb38f98612a7f12dab4dcdc97efa289e3 WHIRLPOOL d1bf17f8bd0e8346d2fff48982c402b0eaa2ea4365b3195e3dd0c4943c93cf1935fdff85a0d2018e43e5074640692c3d72dc72887c86d955dc02c60800e3725b
diff --git a/dev-ros/audio_play/audio_play-0.2.7.ebuild b/dev-ros/audio_play/audio_play-0.2.7.ebuild
new file mode 100644 (file)
index 0000000..d8c6704
--- /dev/null
@@ -0,0 +1,29 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-drivers/audio_common"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Outputs audio to a speaker from a source node"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+       dev-ros/audio_common_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+       dev-ros/roscpp
+       dev-libs/boost:=[threads]
+       media-libs/gstreamer:0.10
+"
+DEPEND="${RDEPEND}
+       virtual/pkgconfig"
+RDEPEND="${RDEPEND}
+       media-plugins/gst-plugins-alsa:0.10
+       media-libs/gst-plugins-good:0.10
+       media-libs/gst-plugins-base:0.10
+"
diff --git a/dev-ros/audio_play/audio_play-9999.ebuild b/dev-ros/audio_play/audio_play-9999.ebuild
new file mode 100644 (file)
index 0000000..d8c6704
--- /dev/null
@@ -0,0 +1,29 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-drivers/audio_common"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Outputs audio to a speaker from a source node"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+       dev-ros/audio_common_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+       dev-ros/roscpp
+       dev-libs/boost:=[threads]
+       media-libs/gstreamer:0.10
+"
+DEPEND="${RDEPEND}
+       virtual/pkgconfig"
+RDEPEND="${RDEPEND}
+       media-plugins/gst-plugins-alsa:0.10
+       media-libs/gst-plugins-good:0.10
+       media-libs/gst-plugins-base:0.10
+"
diff --git a/dev-ros/audio_play/metadata.xml b/dev-ros/audio_play/metadata.xml
new file mode 100644 (file)
index 0000000..c42ea5b
--- /dev/null
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ros</herd>
+</pkgmetadata>