Use newinitd
authorTorsten Veller <tove@gentoo.org>
Sat, 28 Apr 2007 11:55:53 +0000 (11:55 +0000)
committerTorsten Veller <tove@gentoo.org>
Sat, 28 Apr 2007 11:55:53 +0000 (11:55 +0000)
Package-Manager: portage-2.1.2.5

media-video/flumotion/ChangeLog
media-video/flumotion/flumotion-0.4.1.ebuild
media-video/motion/ChangeLog
media-video/motion/motion-3.2.4.ebuild
media-video/motion/motion-3.2.7.ebuild

index 15ecca69ecab05a0db9c0e018c6b99bb74a3789f..07438382492f17b49fa1d41ae41f518995a48c44 100644 (file)
@@ -1,6 +1,9 @@
 # ChangeLog for media-video/flumotion
 # Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/flumotion/ChangeLog,v 1.11 2007/02/20 12:13:57 zaheerm Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/flumotion/ChangeLog,v 1.12 2007/04/28 11:55:53 tove Exp $
+
+  28 Apr 2007; Torsten Veller <tove@gentoo.org> flumotion-0.4.1.ebuild:
+  Use newinitd
 
 *flumotion-0.4.1 (20 Feb 2007)
 
index 1f0df5f9cf0b9eaa42d1a52fab713ad71864134c..65d283f56172a0f5eac8c91fb0c5f7b6004baf0b 100644 (file)
@@ -1,6 +1,6 @@
 # Copyright 1999-2007 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/flumotion/flumotion-0.4.1.ebuild,v 1.1 2007/02/20 12:13:57 zaheerm Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/flumotion/flumotion-0.4.1.ebuild,v 1.2 2007/04/28 11:55:53 tove Exp $
 
 inherit eutils gnome2
 
@@ -76,7 +76,7 @@ src_install() {
        dodir /etc/flumotion/managers/default/flows
        dodir /etc/flumotion/workers
 
-       cd ${S}/conf
+       cd "${S}"/conf
        insinto /etc/flumotion/managers/default
        doins managers/default/planet.xml
        insinto /etc/flumotion/workers
@@ -84,8 +84,7 @@ src_install() {
 
        insinto /etc/flumotion
        doins default.pem
-       exeinto /etc/init.d
-       newexe ${FILESDIR}/flumotion-init-0.2.0 flumotion
+       newinitd "${FILESDIR}"/flumotion-init-0.2.0 flumotion
 
        keepdir /var/run/flumotion
        keepdir /var/log/flumotion
index 593f3eb21864d0953ed7b5e5069baedd89be0360..53d783a58157f27bb960fa74e36e27dd9d5e0728 100644 (file)
@@ -1,6 +1,9 @@
 # ChangeLog for media-video/motion
 # Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/motion/ChangeLog,v 1.12 2007/03/31 18:05:25 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/motion/ChangeLog,v 1.13 2007/04/28 11:52:11 tove Exp $
+
+  28 Apr 2007; Torsten Veller <tove@gentoo.org> motion-3.2.4.ebuild:
+  Use newinitd
 
   31 Mar 2007; Alexis Ballier <aballier@gentoo.org> -motion-3.1.19.ebuild:
   Cleanup old version
index 7e9cb120a2b59edeee5eb775a29c69e130a44ebc..9ee4402a27249a7018729dd4949131b90f2e2a75 100644 (file)
@@ -1,6 +1,6 @@
 # Copyright 1999-2007 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/motion/motion-3.2.4.ebuild,v 1.5 2007/01/05 20:37:39 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/motion/motion-3.2.4.ebuild,v 1.6 2007/04/28 11:52:11 tove Exp $
 
 inherit eutils
 
@@ -34,15 +34,13 @@ src_install() {
        make DESTDIR="${D}" install || die "install failed"
 
        # install init-script
-       dodir /etc/init.d
-       exeinto /etc/init.d
-       newexe ${FILESDIR}/motion.init motion
+       newinitd "${FILESDIR}"/motion.init motion
 
        # copy configuration file
-       cp ${D}/etc/motion-dist.conf ${D}/etc/motion.conf
+       cp "${D}"/etc/motion-dist.conf "${D}"/etc/motion.conf
 
        # cleanup unused files 
-       cd ${D}/usr/share/doc/${P}/examples/
+       cd "${D}"/usr/share/doc/${P}/examples/
        rm motion.init-Debian motion.init-RH motion.init-FreeBSD.sh
 }
 
index e4724ffd215d81561afdabc0579c7ef1a2aeefc6..f5dc752ed804b64e5d3f48a86b87c44148e31bd7 100644 (file)
@@ -1,6 +1,6 @@
 # Copyright 1999-2007 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/motion/motion-3.2.7.ebuild,v 1.4 2007/01/05 20:37:39 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/motion/motion-3.2.7.ebuild,v 1.5 2007/04/28 11:52:11 tove Exp $
 
 inherit eutils
 
@@ -34,13 +34,13 @@ src_install() {
        make DESTDIR="${D}" install || die "install failed"
 
        # install init-script
-       newinitd ${FILESDIR}/motion.init motion || die
+       newinitd "${FILESDIR}"/motion.init motion || die
 
        # copy configuration file
-       cp ${D}/etc/motion-dist.conf ${D}/etc/motion.conf
+       cp "${D}"/etc/motion-dist.conf "${D}"/etc/motion.conf
 
        # cleanup unused files 
-       cd ${D}/usr/share/doc/${P}/examples/
+       cd "${D}"/usr/share/doc/${P}/examples/
        rm motion.init-Debian motion.init-RH motion.init-FreeBSD.sh
 }