dev-libs/protobuf-c: compile-fix ensure new enough dev-libs/protobuf
authorRobin H. Johnson <robbat2@gentoo.org>
Wed, 20 May 2020 05:06:20 +0000 (22:06 -0700)
committerRobin H. Johnson <robbat2@gentoo.org>
Wed, 20 May 2020 05:08:03 +0000 (22:08 -0700)
If the system has an old dev-libs/protobuf-2* installed, then it will
not be upgraded before protobuf-c tries to compile, which leads to
error:
```
t/issue330/issue330.protot/issue330/issue330.proto:1:10:
Unrecognized syntax identifier "proto3".
This parser only recognizes "proto2".
```

Signed-off-by: Robin H. Johnson <robbat2@gentoo.org>
dev-libs/protobuf-c/protobuf-c-1.3.2.ebuild

index d6909a46a3881e5dbdb92532a42756de865411f6..3c3dc101011bd4cee9efd7dc7151d048bd57f98d 100644 (file)
@@ -19,9 +19,9 @@ KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~mips ppc ppc64 s390 sparc x86"
 IUSE="static-libs test"
 RESTRICT="!test? ( test )"
 
-BDEPEND="dev-libs/protobuf:0
+BDEPEND=">=dev-libs/protobuf-3:0
        virtual/pkgconfig[${MULTILIB_USEDEP}]"
-DEPEND="dev-libs/protobuf:0=[${MULTILIB_USEDEP}]"
+DEPEND=">=dev-libs/protobuf-3:0=[${MULTILIB_USEDEP}]"
 RDEPEND="${DEPEND}"
 
 S="${WORKDIR}/${MY_P}"