sys-libs/uclibc-ng: fix ld.so.cache on amd64
authorAnthony G. Basile <blueness@gentoo.org>
Sun, 29 Apr 2018 19:46:13 +0000 (15:46 -0400)
committerAnthony G. Basile <blueness@gentoo.org>
Sun, 29 Apr 2018 19:47:12 +0000 (15:47 -0400)
Package-Manager: Portage-2.3.24, Repoman-2.3.6

sys-libs/uclibc-ng/files/uclibc-ng-1.0.30-fix-ld.so.cache.patch [new file with mode: 0644]
sys-libs/uclibc-ng/uclibc-ng-1.0.30-r1.ebuild [moved from sys-libs/uclibc-ng/uclibc-ng-1.0.30.ebuild with 99% similarity]

diff --git a/sys-libs/uclibc-ng/files/uclibc-ng-1.0.30-fix-ld.so.cache.patch b/sys-libs/uclibc-ng/files/uclibc-ng-1.0.30-fix-ld.so.cache.patch
new file mode 100644 (file)
index 0000000..6b13e08
--- /dev/null
@@ -0,0 +1,48 @@
+commit 92d250d387e247029900c9074150f45866b29781
+Author: Waldemar Brodkorb <wbx@openadk.org>
+Date:   Sun Apr 29 19:34:11 2018 +0200
+
+    Revert "ldconfig: add glibc compatibility fix"
+    
+    This reverts commit 2a3bb4daf5778c5875674cd26a3c75b3d460a042.
+    
+    This is breaking ld.so.cache usage. Seen on Gentoo/amd64.
+    
+    Reported-by: "Anthony G. Basile" <basile@freeharbor.net>
+
+diff --git a/utils/ldconfig.c b/utils/ldconfig.c
+index 58939d689..e6b788118 100644
+--- a/utils/ldconfig.c
++++ b/utils/ldconfig.c
+@@ -184,9 +184,10 @@ static char *readsoname(char *name, FILE *infile, int expected_type,
+               res = readsoname32(name, infile, expected_type, type);
+       else {
+               res = readsoname64(name, infile, expected_type, type);
+-
+-              // For 64-bit glibc compatibility
+-              *type |= FLAG_X8664_LIB64;
++#if 0
++              /* relies on multilib support which we dont have ... */
++              *type |= LIB_ELF64;
++#endif
+       }
+       return res;
+@@ -757,7 +758,7 @@ void cache_print(void)
+       for (fd = 0; fd < header->nlibs; fd++) {
+               printf("\t%s ", strs + libent[fd].sooffset);
+-              switch (libent[fd].flags & ~LIB_ELF64 & FLAG_TYPE_MASK) {
++              switch (libent[fd].flags & ~LIB_ELF64) {
+               case LIB_DLL:
+                       printf("(libc4)");
+                       break;
+@@ -770,7 +771,7 @@ void cache_print(void)
+               case LIB_ELF_LIBC5:
+               case LIB_ELF_LIBC6:
+                       printf("(libc%d%s)",
+-                             (libent[fd].flags & ~LIB_ELF64 & FLAG_TYPE_MASK) + 3,
++                             (libent[fd].flags & ~LIB_ELF64) + 3,
+                              libent[fd].flags & LIB_ELF64 ? "/64" : "");
+                       break;
+               default:
similarity index 99%
rename from sys-libs/uclibc-ng/uclibc-ng-1.0.30.ebuild
rename to sys-libs/uclibc-ng/uclibc-ng-1.0.30-r1.ebuild
index 3b31357d8044d9858d4d508e0bd435516ef41236..ca35a2cc5bc49b5ccd06d5c27cbcbc64215c35b9 100644 (file)
@@ -252,6 +252,9 @@ src_prepare() {
        # We want to get rid of this and just have ABI = 0.
        eapply "${FILESDIR}"/uclibc-compat-r1.patch
 
+       # Critical fix for ld.so.cache
+       eapply "${FILESDIR}"/${P}-fix-ld.so.cache.patch
+
        # We need to change the major.minor.sublevel of uclibc-ng.
        # Upstream sets MAJOR_VERSION = 1 which breaks runtime linking.
        # If we really want the ABI bump, we'll have to hack the gcc