Revert "app-emacs/yasnippet: drop old EAPI"
authorUlrich Müller <ulm@gentoo.org>
Fri, 8 Jun 2018 18:40:14 +0000 (20:40 +0200)
committerUlrich Müller <ulm@gentoo.org>
Fri, 8 Jun 2018 18:40:38 +0000 (20:40 +0200)
Please don't remove ebuilds without talking to the maintainer.
This package was very recently bumped, and the new version contains
major changes. So we should give users two weeks before removing the
old version.

In addition, the removal left a stale files/50yasnippet-gentoo.el
site-init file.

This reverts commit ad4ab77e9c888b6f299067f2ea89daac7459dcec.

app-emacs/yasnippet/Manifest
app-emacs/yasnippet/yasnippet-0.6.1c.ebuild [new file with mode: 0644]

index a590a9403f4861813b5773cb25666cbad2096f5d..730ee2c486e73761f26e9943ba4d5c35d13b30c7 100644 (file)
@@ -1 +1,3 @@
 DIST yasnippet-0.13.0.tar.gz 577330 BLAKE2B 21830c0a2e99d7669093c16f527debb4921e96aad006887ec1c7e35da58745721658417f1aec96ea78ba4dc5f3951c857848fce67e6d2ff7f255d4aea5687ab9 SHA512 73b111f72e98c4183764cef08ddfaa861dba49f171f96026b074bf62a7aa5e2d8529f616805ba386dd4157b675da953784d5bcd832d6015ce1b72e9c240988c5
+DIST yasnippet-0.6.1c.tar.bz2 47493 BLAKE2B d3bb0d1c343c05f9bc212a0fc114d3c816c02d8de685c55c0f3407a02ee6d1c1e6c24681872dc66e67af773e0e98a78a0366bbfe72ebfd543c5174d2e2f994b0 SHA512 ea4c5850ae80e4db9a188788654a099eddc43e29371ef0cb6367e1a39d3ee9f3e9dab7201178955ae47c92bcecbb5120e0b817e47e9c88c5bcef9e561636a603
+DIST yasnippet-doc-0.6.1c.tar.bz2 490738 BLAKE2B e312481c7693094d62eb0aec465412ea1c894ca5132df9c2beba49c3c78daaec90ca80d17fc9404edbdd8cea1fce63804a102cbe9b7d3d7b23f0761b8a0ea552 SHA512 c96955cac11f319107e0ea907c92860049598cbfd47b6a2e3211dc2b030face77b03aa9495d7e9d78171be87083f77268e90c6c86b0cc467a96a5bd724daf8f1
diff --git a/app-emacs/yasnippet/yasnippet-0.6.1c.ebuild b/app-emacs/yasnippet/yasnippet-0.6.1c.ebuild
new file mode 100644 (file)
index 0000000..831ffed
--- /dev/null
@@ -0,0 +1,48 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=0
+
+inherit elisp
+
+DESCRIPTION="Yet another snippet extension for Emacs"
+HOMEPAGE="https://github.com/capitaomorte/yasnippet"
+SRC_URI="https://yasnippet.googlecode.com/files/${P}.tar.bz2
+       doc? ( https://yasnippet.googlecode.com/files/${PN}-doc-${PV}.tar.bz2 )"
+
+# Homepage says MIT licence, source contains GPL-2 copyright notice
+LICENSE="MIT GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+DEPEND=">=app-emacs/dropdown-list-20080316"
+RDEPEND="${DEPEND}"
+
+SITEFILE="50${PN}-gentoo.el"
+
+src_unpack() {
+       elisp_src_unpack
+
+       # remove bundled copy of dropdown-list
+       rm "${S}/dropdown-list.el" || die
+}
+
+src_install() {
+       elisp_src_install
+
+       insinto "${SITEETC}/${PN}"
+       doins -r snippets || die "doins failed"
+
+       if use doc; then
+               dohtml -r "${WORKDIR}"/doc/* || die "dohtml failed"
+       fi
+}
+
+pkg_postinst() {
+       elisp-site-regen
+
+       elog "Please add the following code into your .emacs to use yasnippet:"
+       elog "(yas/initialize)"
+       elog "(yas/load-directory \"${SITEETC}/${PN}/snippets\")"
+}