sys-firmware/intel-microcode: drop old
authorThomas Deutschmann <whissi@gentoo.org>
Mon, 14 Jan 2019 02:38:49 +0000 (03:38 +0100)
committerThomas Deutschmann <whissi@gentoo.org>
Mon, 14 Jan 2019 02:38:49 +0000 (03:38 +0100)
Package-Manager: Portage-2.3.55, Repoman-2.3.12
Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
sys-firmware/intel-microcode/Manifest
sys-firmware/intel-microcode/intel-microcode-20180807a_p20181117.ebuild [deleted file]
sys-firmware/intel-microcode/intel-microcode-20180807a_p20181215.ebuild [deleted file]

index c35614983ee8216f48b5a9e463c09e587d0ceac6..e6f978da2076b69aa050965ec31790682c9d4f9c 100644 (file)
@@ -1,4 +1,2 @@
-DIST intel-microcode-collection-20181117.tar.xz 4454740 BLAKE2B c9f106a6c6477966d535faef6a6a6a547218b0162ed6405dd9ab47967a87b2c4d9d2d33e8caf716720179bb0035df8c4a38d06c654584396f2af82828fcabd5e SHA512 cdff0e9d88c7848746487710c17cbcdf2adb0940072d71d6f32651a7e2fb66751409856e28d36e7e156e1bae08ad6575098972572bf809db5f07023870b2b9c6
-DIST intel-microcode-collection-20181215.tar.xz 4455584 BLAKE2B 7535283f38ce82cc7e90f45e3201665e46b3c00becd3f6432843c3d960f0a8f11b8c394bc736e7c02e9e34ea31832bd7335603f8727f114f5d3eafa7fb6ea630 SHA512 ec32ef3c625426c98902b7716abc400001c440b8136f13ba89e0dd707690f82dd5afd8849b61f86507b3a78ef7a96b8750dca24fdf4c42b53275fa87e50ed561
 DIST intel-microcode-collection-20190112.tar.xz 4748576 BLAKE2B a6db3a1b357bdd1db65885b0de0d8a871573b6ec025eaff6c8991ef03eed6f32f298ecb736b42e09a94ca880ace984b276672245f5651982093d405abd588712 SHA512 6602772bd44aa9fad27275d515f73db041c3e18964fdfbea8d5f7917d456e5a5ca343999b7a9b48245b115290490c525e24cd575532ba8b2169a8229a69b9fa4
 DIST microcode-20180807a.tgz 1628061 BLAKE2B a6b5a07596a0b1687efb95c207b2194865b2f975cc0d761a687d5b9d8fea63e777eb73373113f356a18592fd53651cf37d044d4e98cdfe6b306393b54ac06129 SHA512 3cd6794a5ce26e86f7b644e523ba978699316046e593da215b73b17c4b43049ac4a81636e2ce3e727d06c2efbac98657764aa3ff355edb429127585bb49a9b10
diff --git a/sys-firmware/intel-microcode/intel-microcode-20180807a_p20181117.ebuild b/sys-firmware/intel-microcode/intel-microcode-20180807a_p20181117.ebuild
deleted file mode 100644 (file)
index cf35c11..0000000
+++ /dev/null
@@ -1,253 +0,0 @@
-# Copyright 1999-2018 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="6"
-
-inherit linux-info toolchain-funcs mount-boot
-
-# Find updates by searching and clicking the first link (hopefully it's the one):
-# https://www.intel.com/content/www/us/en/search.html?keyword=Processor+Microcode+Data+File
-
-COLLECTION_SNAPSHOT="${PV##*_p}"
-INTEL_SNAPSHOT="${PV/_p*}"
-NUM="28087"
-DESCRIPTION="Intel IA32/IA64 microcode update data"
-HOMEPAGE="http://inertiawar.com/microcode/ https://downloadcenter.intel.com/Detail_Desc.aspx?DwnldID=${NUM}"
-SRC_URI="https://downloadmirror.intel.com/${NUM}/eng/microcode-${INTEL_SNAPSHOT}.tgz
-       https://dev.gentoo.org/~whissi/dist/intel-microcode/intel-microcode-collection-${COLLECTION_SNAPSHOT}.tar.xz"
-
-LICENSE="intel-ucode"
-SLOT="0"
-KEYWORDS="-* amd64 x86"
-IUSE="hostonly initramfs +split-ucode vanilla"
-REQUIRED_USE="|| ( initramfs split-ucode )"
-
-DEPEND="sys-apps/iucode_tool"
-
-# !<sys-apps/microcode-ctl-1.17-r2 due to bug #268586
-RDEPEND="hostonly? ( sys-apps/iucode_tool )"
-
-RESTRICT="binchecks bindist mirror strip"
-
-S=${WORKDIR}
-
-# Blacklist bad microcode here.
-# 0x000406f1 aka 06-4f-01 aka CPUID 406F1 require newer microcode loader
-MICROCODE_BLACKLIST_DEFAULT="-s !0x000406f1"
-MICROCODE_BLACKLIST="${MICROCODE_BLACKLIST:=${MICROCODE_BLACKLIST_DEFAULT}}"
-
-# In case we want to set some defaults ...
-MICROCODE_SIGNATURES_DEFAULT=""
-
-# Advanced users only:
-# merge with:
-# only current CPU: MICROCODE_SIGNATURES="-S"
-# only specific CPU: MICROCODE_SIGNATURES="-s 0x00000f4a -s 0x00010676"
-# exclude specific CPU: MICROCODE_SIGNATURES="-s !0x00000686"
-MICROCODE_SIGNATURES="${MICROCODE_SIGNATURES:=${MICROCODE_SIGNATURES_DEFAULT}}"
-
-pkg_pretend() {
-       use initramfs && mount-boot_pkg_pretend
-}
-
-src_prepare() {
-       default
-
-       # Prevent "invalid file format" errors from iucode_tool
-       rm -f "${S}"/intel-ucod*/list || die
-}
-
-src_install() {
-       # This will take ALL of the upstream microcode sources:
-       # - microcode.dat
-       # - intel-ucode/
-       # In some cases, they have not contained the same content (eg the directory has newer stuff).
-       MICROCODE_SRC=(
-               "${S}"/intel-ucode/
-               "${S}"/intel-ucode-with-caveats/
-       )
-
-       # Allow users who are scared about microcode updates not included in Intel's official
-       # microcode tarball to opt-out and comply with Intel marketing
-       if ! use vanilla; then
-               MICROCODE_SRC+=( "${S}"/intel-microcode-collection-${COLLECTION_SNAPSHOT} )
-       fi
-
-       opts=(
-               ${MICROCODE_BLACKLIST}
-               ${MICROCODE_SIGNATURES}
-               # be strict about what we are doing
-               --overwrite
-               --strict-checks
-               --no-ignore-broken
-               # we want to install latest version
-               --no-downgrade
-               # show everything we find
-               --list-all
-               # show what we selected
-               --list
-       )
-
-       # The earlyfw cpio needs to be in /boot because it must be loaded before
-       # rootfs is mounted.
-       use initramfs && dodir /boot && opts+=( --write-earlyfw="${ED%/}"/boot/intel-uc.img )
-       # split location (we use a temporary location so that we are able
-       # to re-run iucode_tool in pkg_preinst; use keepdir instead of dodir to carry
-       # this folder to pkg_preinst to avoid an error even if no microcode was selected):
-       keepdir /tmp/intel-ucode && opts+=( --write-firmware="${ED%/}"/tmp/intel-ucode )
-
-       iucode_tool \
-               "${opts[@]}" \
-               "${MICROCODE_SRC[@]}" \
-               || die "iucode_tool ${opts[@]} ${MICROCODE_SRC[@]}"
-
-       dodoc releasenote
-
-       # Record how package was created so we can show this in build.log
-       # even for binary packages.
-       if [[ "${MICROCODE_BLACKLIST}" != "${MICROCODE_BLACKLIST_DEFAULT}" ]]; then
-               echo ${MICROCODE_BLACKLIST} > "${ED%/}/tmp/.blacklist_altered" || die "Failed to add marker that MICROCODE_BLACKLIST variable was used"
-       fi
-
-       if [[ "${MICROCODE_SIGNATURES}" != "${MICROCODE_SIGNATURES_DEFAULT}" ]]; then
-               echo ${MICROCODE_SIGNATURES} > "${ED%/}/tmp/.signatures_altered" || die "Failed to add marker that MICROCODE_SIGNATURES variable was used"
-       fi
-}
-
-pkg_preinst() {
-       if [[ -f "${ED%/}/tmp/.blacklist_altered" ]]; then
-               local _recorded_MICROCODE_BLACKLIST_value=$(cat "${ED%/}/tmp/.blacklist_altered")
-               ewarn "MICROCODE_BLACKLIST is set to \"${_recorded_MICROCODE_BLACKLIST_value}\" instead of default \"${MICROCODE_BLACKLIST_DEFAULT}\". You are on your own!"
-       fi
-
-       if [[ -f "${ED%/}/tmp/.signatures_altered" ]]; then
-               local _recorded_MICROCODE_SIGNATURES_value=$(cat "${ED%/}/tmp/.signatures_altered")
-               ewarn "Package was created using advanced options:"
-               ewarn "MICROCODE_SIGNATURES is set to \"${_recorded_MICROCODE_SIGNATURES_value}\" instead of default \"${MICROCODE_SIGNATURES_DEFAULT}\"!"
-       fi
-
-       # Make sure /boot is available if needed.
-       use initramfs && mount-boot_pkg_preinst
-
-       local _initramfs_file="${ED%/}/boot/intel-uc.img"
-       local _ucode_dir="${ED%/}/lib/firmware/intel-ucode"
-
-       if use hostonly; then
-               # While this output looks redundant we do this check to detect
-               # rare cases where iucode_tool was unable to detect system's processor(s).
-               local _detected_processors=$(iucode_tool --scan-system 2>&1)
-               if [[ -z "${_detected_processors}" ]]; then
-                       ewarn "Looks like iucode_tool was unable to detect any processor!"
-               else
-                       einfo "Only installing ucode(s) for ${_detected_processors#iucode_tool: system has } due to USE=hostonly ..."
-               fi
-
-               opts=(
-                       --scan-system
-                       # be strict about what we are doing
-                       --overwrite
-                       --strict-checks
-                       --no-ignore-broken
-                       # we want to install latest version
-                       --no-downgrade
-                       # show everything we find
-                       --list-all
-                       # show what we selected
-                       --list
-               )
-
-               # The earlyfw cpio needs to be in /boot because it must be loaded before
-               # rootfs is mounted.
-               use initramfs && opts+=( --write-earlyfw=${_initramfs_file} )
-               # split location:
-               use split-ucode && dodir /lib/firmware/intel-ucode && opts+=( --write-firmware=${_ucode_dir} )
-
-               iucode_tool \
-                       "${opts[@]}" \
-                       "${ED%/}"/tmp/intel-ucode \
-                       || die "iucode_tool ${opts[@]} ${ED%/}/tmp/intel-ucode"
-
-       else
-               if use split-ucode; then
-                       # Temporary /tmp/intel-ucode will become final /lib/firmware/intel-ucode ...
-                       dodir /lib/firmware
-                       mv "${ED%/}/tmp/intel-ucode" "${ED%/}/lib/firmware" || die "Failed to install splitted ucodes!"
-               fi
-       fi
-
-       # Because it is possible that this package will install not one single file
-       # due to user selection which is still somehow unexpected we add the following
-       # check to inform user so that the user has at least a chance to detect
-       # a problem/invalid select.
-       local _has_installed_something=
-       if use initramfs && [[ -s "${_initramfs_file}" ]]; then
-               _has_installed_something="yes"
-       elif use split-ucode; then
-               _has_installed_something=$(find "${_ucode_dir}" -maxdepth 0 -not -empty -exec echo yes \;)
-       fi
-
-       if use hostonly && [[ -n "${_has_installed_something}" ]]; then
-               elog "You only installed ucode(s) for all currently available (=online)"
-               elog "processor(s). Remember to re-emerge this package whenever you"
-               elog "change the system's processor model."
-               elog ""
-       elif [[ -z "${_has_installed_something}" ]]; then
-               ewarn "WARNING:"
-               if [[ -f "${ED%/}/tmp/.signatures_altered" ]]; then
-                       ewarn "No ucode was installed! Because you have created this package"
-                       ewarn "using MICROCODE_SIGNATURES variable please double check if you"
-                       ewarn "have an invalid select."
-                       ewarn "It's rare but it is also possible that just no ucode update"
-                       ewarn "is available for your processor(s). In this case it is safe"
-                       ewarn "to ignore this warning."
-               else
-                       ewarn "No ucode was installed! It's rare but it is also possible"
-                       ewarn "that just no ucode update is available for your processor(s)."
-                       ewarn "In this case it is safe to ignore this warning."
-               fi
-
-               ewarn ""
-
-               if use hostonly; then
-                       ewarn "Unset \"hostonly\" USE flag to install all available ucodes."
-                       ewarn ""
-               fi
-       fi
-
-       # Cleanup any temporary leftovers so that we don't merge any
-       # unneeded files on disk.
-       rm -r "${ED%/}/tmp" || die "Failed to cleanup '${ED%/}/tmp'"
-}
-
-pkg_prerm() {
-       # Make sure /boot is mounted so that we can remove /boot/intel-uc.img!
-       use initramfs && mount-boot_pkg_prerm
-}
-
-pkg_postrm() {
-       # Don't forget to umount /boot if it was previously mounted by us.
-       use initramfs && mount-boot_pkg_postrm
-}
-
-pkg_postinst() {
-       # Don't forget to umount /boot if it was previously mounted by us.
-       use initramfs && mount-boot_pkg_postinst
-
-       # We cannot give detailed information if user is affected or not:
-       # If MICROCODE_BLACKLIST wasn't modified, user can still use MICROCODE_SIGNATURES
-       # to to force a specific, otherwise blacklisted, microcode. So we
-       # only show a generic warning based on running kernel version:
-       if kernel_is -lt 4 14 34; then
-               ewarn "${P} contains microcode updates which require"
-               ewarn "additional kernel patches which aren't yet included in kernel <4.14.34."
-               ewarn "Loading such a microcode through kernel interface from an unpatched kernel"
-               ewarn "can crash your system!"
-               ewarn ""
-               ewarn "Those microcodes are blacklisted per default. However, if you have altered"
-               ewarn "MICROCODE_BLACKLIST or MICROCODE_SIGNATURES, you maybe have unintentionally"
-               ewarn "re-enabled those microcodes...!"
-               ewarn ""
-               ewarn "Check \"${EROOT%/}/usr/share/doc/${PN}-*/releasenot*\" if your microcode update"
-               ewarn "requires additional kernel patches or not."
-       fi
-}
diff --git a/sys-firmware/intel-microcode/intel-microcode-20180807a_p20181215.ebuild b/sys-firmware/intel-microcode/intel-microcode-20180807a_p20181215.ebuild
deleted file mode 100644 (file)
index e284cd8..0000000
+++ /dev/null
@@ -1,239 +0,0 @@
-# Copyright 1999-2018 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="6"
-
-inherit linux-info toolchain-funcs mount-boot
-
-# Find updates by searching and clicking the first link (hopefully it's the one):
-# https://www.intel.com/content/www/us/en/search.html?keyword=Processor+Microcode+Data+File
-
-COLLECTION_SNAPSHOT="${PV##*_p}"
-INTEL_SNAPSHOT="${PV/_p*}"
-NUM="28087"
-DESCRIPTION="Intel IA32/IA64 microcode update data"
-HOMEPAGE="http://inertiawar.com/microcode/ https://downloadcenter.intel.com/Detail_Desc.aspx?DwnldID=${NUM}"
-SRC_URI="https://downloadmirror.intel.com/${NUM}/eng/microcode-${INTEL_SNAPSHOT}.tgz
-       https://dev.gentoo.org/~whissi/dist/intel-microcode/intel-microcode-collection-${COLLECTION_SNAPSHOT}.tar.xz"
-
-LICENSE="intel-ucode"
-SLOT="0"
-KEYWORDS="-* amd64 x86"
-IUSE="hostonly initramfs +split-ucode vanilla"
-REQUIRED_USE="|| ( initramfs split-ucode )"
-
-DEPEND="sys-apps/iucode_tool"
-
-# !<sys-apps/microcode-ctl-1.17-r2 due to bug #268586
-RDEPEND="hostonly? ( sys-apps/iucode_tool )"
-
-RESTRICT="binchecks bindist mirror strip"
-
-S=${WORKDIR}
-
-# Blacklist bad microcode here.
-# 0x000406f1 aka 06-4f-01 aka CPUID 406F1 require newer microcode loader
-MICROCODE_BLACKLIST_DEFAULT="-s !0x000406f1"
-
-# In case we want to set some defaults ...
-MICROCODE_SIGNATURES_DEFAULT=""
-
-# Advanced users only!
-# Set MIRCOCODE_SIGNATURES to merge with:
-# only current CPU: MICROCODE_SIGNATURES="-S"
-# only specific CPU: MICROCODE_SIGNATURES="-s 0x00000f4a -s 0x00010676"
-# exclude specific CPU: MICROCODE_SIGNATURES="-s !0x00000686"
-
-pkg_pretend() {
-       use initramfs && mount-boot_pkg_pretend
-}
-
-src_prepare() {
-       default
-
-       # Prevent "invalid file format" errors from iucode_tool
-       rm -f "${S}"/intel-ucod*/list || die
-}
-
-src_install() {
-       # This will take ALL of the upstream microcode sources:
-       # - microcode.dat
-       # - intel-ucode/
-       # In some cases, they have not contained the same content (eg the directory has newer stuff).
-       MICROCODE_SRC=(
-               "${S}"/intel-ucode/
-               "${S}"/intel-ucode-with-caveats/
-       )
-
-       # Allow users who are scared about microcode updates not included in Intel's official
-       # microcode tarball to opt-out and comply with Intel marketing
-       if ! use vanilla; then
-               MICROCODE_SRC+=( "${S}"/intel-microcode-collection-${COLLECTION_SNAPSHOT} )
-       fi
-
-       # These will carry into pkg_preinst via env saving.
-       : ${MICROCODE_BLACKLIST=${MICROCODE_BLACKLIST_DEFAULT}}
-       : ${MICROCODE_SIGNATURES=${MICROCODE_SIGNATUES_DEFAULT}}
-
-       opts=(
-               ${MICROCODE_BLACKLIST}
-               ${MICROCODE_SIGNATURES}
-               # be strict about what we are doing
-               --overwrite
-               --strict-checks
-               --no-ignore-broken
-               # we want to install latest version
-               --no-downgrade
-               # show everything we find
-               --list-all
-               # show what we selected
-               --list
-       )
-
-       # The earlyfw cpio needs to be in /boot because it must be loaded before
-       # rootfs is mounted.
-       use initramfs && dodir /boot && opts+=( --write-earlyfw="${ED%/}"/boot/intel-uc.img )
-
-       keepdir /lib/firmware/intel-ucode
-       opts+=( --write-firmware="${ED%/}/lib/firmware/intel-ucode" )
-
-       iucode_tool \
-               "${opts[@]}" \
-               "${MICROCODE_SRC[@]}" \
-               || die "iucode_tool ${opts[@]} ${MICROCODE_SRC[@]}"
-
-       dodoc releasenote
-}
-
-pkg_preinst() {
-       if [[ ${MICROCODE_BLACKLIST} != ${MICROCODE_BLACKLIST_DEFAULT} ]]; then
-               ewarn "MICROCODE_BLACKLIST is set to \"${MICROCODE_BLACKLIST}\" instead of default \"${MICROCODE_BLACKLIST_DEFAULT}\". You are on your own!"
-       fi
-
-       if [[ ${MICROCODE_SIGNATURES} != ${MICROCODE_SIGNATURES_DEFAULT} ]]; then
-               ewarn "Package was created using advanced options:"
-               ewarn "MICROCODE_SIGNATURES is set to \"${MICROCODE_SIGNATURES}\" instead of default \"${MICROCODE_SIGNATURES_DEFAULT}\"!"
-       fi
-
-       # Make sure /boot is available if needed.
-       use initramfs && mount-boot_pkg_preinst
-
-       local _initramfs_file="${ED%/}/boot/intel-uc.img"
-
-       if use hostonly; then
-               # While this output looks redundant we do this check to detect
-               # rare cases where iucode_tool was unable to detect system's processor(s).
-               local _detected_processors=$(iucode_tool --scan-system 2>&1)
-               if [[ -z "${_detected_processors}" ]]; then
-                       ewarn "Looks like iucode_tool was unable to detect any processor!"
-               else
-                       einfo "Only installing ucode(s) for ${_detected_processors#iucode_tool: system has } due to USE=hostonly ..."
-               fi
-
-               opts=(
-                       --scan-system
-                       # be strict about what we are doing
-                       --overwrite
-                       --strict-checks
-                       --no-ignore-broken
-                       # we want to install latest version
-                       --no-downgrade
-                       # show everything we find
-                       --list-all
-                       # show what we selected
-                       --list
-               )
-
-               # The earlyfw cpio needs to be in /boot because it must be loaded before
-               # rootfs is mounted.
-               use initramfs && opts+=( --write-earlyfw=${_initramfs_file} )
-
-               if use split-ucode; then
-                       opts+=( --write-firmware="${ED%/}/lib/firmware/intel-ucode" )
-               fi
-
-               opts+=( "${ED%/}"/lib/firmware/intel-ucode-temp )
-
-               mv "${ED%/}"/lib/firmware/intel-ucode{,-temp} || die
-               keepdir /lib/firmware/intel-ucode
-
-               iucode_tool "${opts[@]}" || die "iucode_tool ${opts[@]}"
-
-               rm -r "${ED%/}"/lib/firmware/intel-ucode-temp || die
-
-       elif ! use split-ucode; then # hostonly disabled
-               rm -r "${ED%/}"/lib/firmware/intel-ucode || die
-       fi
-
-       # Because it is possible that this package will install not one single file
-       # due to user selection which is still somehow unexpected we add the following
-       # check to inform user so that the user has at least a chance to detect
-       # a problem/invalid select.
-       local _has_installed_something=
-       if use initramfs && [[ -s "${_initramfs_file}" ]]; then
-               _has_installed_something="yes"
-       elif use split-ucode; then
-               _has_installed_something=$(find "${ED%/}/lib/firmware/intel-ucode" -maxdepth 0 -not -empty -exec echo yes \;)
-       fi
-
-       if use hostonly && [[ -n "${_has_installed_something}" ]]; then
-               elog "You only installed ucode(s) for all currently available (=online)"
-               elog "processor(s). Remember to re-emerge this package whenever you"
-               elog "change the system's processor model."
-               elog ""
-       elif [[ -z "${_has_installed_something}" ]]; then
-               ewarn "WARNING:"
-               if [[ ${MICROCODE_SIGNATURES} != ${MICROCODE_SIGNATURES_DEFAULT} ]]; then
-                       ewarn "No ucode was installed! Because you have created this package"
-                       ewarn "using MICROCODE_SIGNATURES variable please double check if you"
-                       ewarn "have an invalid select."
-                       ewarn "It's rare but it is also possible that just no ucode update"
-                       ewarn "is available for your processor(s). In this case it is safe"
-                       ewarn "to ignore this warning."
-               else
-                       ewarn "No ucode was installed! It's rare but it is also possible"
-                       ewarn "that just no ucode update is available for your processor(s)."
-                       ewarn "In this case it is safe to ignore this warning."
-               fi
-
-               ewarn ""
-
-               if use hostonly; then
-                       ewarn "Unset \"hostonly\" USE flag to install all available ucodes."
-                       ewarn ""
-               fi
-       fi
-}
-
-pkg_prerm() {
-       # Make sure /boot is mounted so that we can remove /boot/intel-uc.img!
-       use initramfs && mount-boot_pkg_prerm
-}
-
-pkg_postrm() {
-       # Don't forget to umount /boot if it was previously mounted by us.
-       use initramfs && mount-boot_pkg_postrm
-}
-
-pkg_postinst() {
-       # Don't forget to umount /boot if it was previously mounted by us.
-       use initramfs && mount-boot_pkg_postinst
-
-       # We cannot give detailed information if user is affected or not:
-       # If MICROCODE_BLACKLIST wasn't modified, user can still use MICROCODE_SIGNATURES
-       # to to force a specific, otherwise blacklisted, microcode. So we
-       # only show a generic warning based on running kernel version:
-       if kernel_is -lt 4 14 34; then
-               ewarn "${P} contains microcode updates which require"
-               ewarn "additional kernel patches which aren't yet included in kernel <4.14.34."
-               ewarn "Loading such a microcode through kernel interface from an unpatched kernel"
-               ewarn "can crash your system!"
-               ewarn ""
-               ewarn "Those microcodes are blacklisted per default. However, if you have altered"
-               ewarn "MICROCODE_BLACKLIST or MICROCODE_SIGNATURES, you maybe have unintentionally"
-               ewarn "re-enabled those microcodes...!"
-               ewarn ""
-               ewarn "Check \"${EROOT%/}/usr/share/doc/${PN}-*/releasenot*\" if your microcode update"
-               ewarn "requires additional kernel patches or not."
-       fi
-}