dev-perl/PPI-PowerToys: Add build fix for Perl 5.26, bug 623080
authorAndreas K. Hüttel <dilfridge@gentoo.org>
Sun, 2 Jul 2017 15:30:42 +0000 (17:30 +0200)
committerAndreas K. Hüttel <dilfridge@gentoo.org>
Sun, 2 Jul 2017 15:30:42 +0000 (17:30 +0200)
Package-Manager: Portage-2.3.6, Repoman-2.3.2

dev-perl/PPI-PowerToys/PPI-PowerToys-0.140.0.ebuild

index cf1a70541f1365601d62fe9b899d08d400e54200..557307d6dff1cd9bb6e95dd51ce8376e4001e381 100644 (file)
@@ -1,21 +1,20 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=5
+EAPI=6
 
-MODULE_AUTHOR="ADAMK"
-MODULE_VERSION=0.14
+DIST_AUTHOR="ADAMK"
+DIST_VERSION=0.14
 
 inherit perl-module
 
 DESCRIPTION="A handy collection of small PPI-based utilities"
 
-LICENSE="|| ( Artistic GPL-1 GPL-2 GPL-3 )"
 SLOT="0"
 KEYWORDS="~amd64"
 IUSE=""
 
-DEPEND="
+RDEPEND="
        >=dev-perl/File-Find-Rule-0.32
        >=dev-perl/File-Find-Rule-Perl-1.10
        >=dev-perl/Test-Script-1.70.0
@@ -23,3 +22,10 @@ DEPEND="
        dev-perl/PPI
        dev-perl/IPC-Run3
 "
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+       sed -i -e 's/use inc::Module::Install::DSL/use lib q[.];\nuse inc::Module::Install::DSL/' Makefile.PL ||
+               die "Can't patch Makefile.PL for 5.26 dot-in-inc"
+       perl-module_src_prepare
+}