Version bump to 2.0.1, which fixes quite a few minor bugs in 2.0, and removing an...
authorChris Gianelloni <wolf31o2@gentoo.org>
Wed, 20 Dec 2006 15:20:33 +0000 (15:20 +0000)
committerChris Gianelloni <wolf31o2@gentoo.org>
Wed, 20 Dec 2006 15:20:33 +0000 (15:20 +0000)
Package-Manager: portage-2.1.2_rc3-r4

dev-util/catalyst/ChangeLog
dev-util/catalyst/catalyst-2.0.1.ebuild [new file with mode: 0644]
dev-util/catalyst/files/digest-catalyst-2.0.1 [new file with mode: 0644]

index 1499a29d0cb5436db7bff5aa354b4c9020ac2670..f560e7342b0560e648e269e9c8dfa4c9dcd24887 100644 (file)
@@ -1,6 +1,13 @@
 # ChangeLog for dev-util/catalyst
 # Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/catalyst/ChangeLog,v 1.156 2006/11/07 16:39:26 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/catalyst/ChangeLog,v 1.157 2006/12/20 15:20:33 wolf31o2 Exp $
+
+*catalyst-2.0.1 (20 Dec 2006)
+
+  20 Dec 2006; Chris Gianelloni <wolf31o2@gentoo.org>
+  -files/catalyst-2.0_rc50-slot.patch, +catalyst-2.0.1.ebuild:
+  Version bump to 2.0.1, which fixes quite a few minor bugs in 2.0, and
+  removing an unused patch.
 
   07 Nov 2006; Chris Gianelloni <wolf31o2@gentoo.org>
   -catalyst-2.0_rc50.ebuild:
diff --git a/dev-util/catalyst/catalyst-2.0.1.ebuild b/dev-util/catalyst/catalyst-2.0.1.ebuild
new file mode 100644 (file)
index 0000000..22b566f
--- /dev/null
@@ -0,0 +1,76 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/catalyst/catalyst-2.0.1.ebuild,v 1.1 2006/12/20 15:20:33 wolf31o2 Exp $
+
+inherit eutils
+
+DESCRIPTION="Gentoo Linux official release metatool"
+HOMEPAGE="http://www.gentoo.org/proj/en/releng/catalyst"
+SRC_URI="http://dev.gentoo.org/~wolf31o2/sources/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="ccache cdr"
+
+DEPEND=""
+RDEPEND="dev-lang/python
+       app-crypt/shash
+       amd64? ( sys-apps/setarch )
+       ppc64? ( sys-apps/setarch )
+       ccache? ( dev-util/ccache )
+       cdr? (
+               virtual/cdrtools
+               ia64? ( sys-fs/dosfstools )
+               app-misc/zisofs-tools
+               >=sys-fs/squashfs-tools-2.1 )"
+
+pkg_setup() {
+       if use ccache ; then
+               einfo "Enabling ccache support for catalyst."
+       else
+               ewarn "By default, ccache support for catalyst is disabled."
+               ewarn "If this is not what you intended,"
+               ewarn "then you should add ccache to your USE."
+       fi
+       echo
+       einfo "The template spec files are now installed by default.  You can find"
+       einfo "them under /usr/share/doc/${PF}/examples"
+       einfo "and they are considered to be the authorative source of information"
+       einfo "on catalyst."
+}
+
+src_install() {
+       insinto /usr/lib/${PN}/arch
+       doins arch/* || die "copying arch/*"
+       insinto /usr/lib/${PN}/modules
+       doins modules/* || die "copying modules/*"
+       insinto /usr/lib/${PN}/livecd/cdtar
+       doins livecd/cdtar/* || die "copying cdtar/*"
+       insinto /usr/lib/${PN}/livecd/files
+       doins livecd/files/* || die "copying files/*"
+       for x in targets/*; do
+               exeinto /usr/lib/${PN}/$x
+               doexe $x/* || die "copying ${x}"
+       done
+       exeinto /usr/lib/${PN}
+       doexe catalyst || die "copying catalyst"
+       dodir /usr/bin
+       dosym /usr/lib/${PN}/catalyst /usr/bin/catalyst
+       insinto /etc/catalyst
+       doins files/catalyst.conf || die "copying catalyst.conf"
+       DOCDESTTREE="." dohtml -A spec,msg,example -r examples files
+       dodoc README ChangeLog ChangeLog.old AUTHORS
+       doman files/catalyst.1
+       # Here is where we actually enable ccache
+       use ccache && \
+               dosed 's:options="autoresume kern:options="autoresume ccache kern:' \
+               /etc/catalyst/catalyst.conf
+}
+
+pkg_postinst() {
+       einfo "You can find more information about catalyst by checking out the"
+       einfo "catalyst project page at:"
+       einfo "http://www.gentoo.org/proj/en/releng/catalyst/index.xml"
+       echo
+}
diff --git a/dev-util/catalyst/files/digest-catalyst-2.0.1 b/dev-util/catalyst/files/digest-catalyst-2.0.1
new file mode 100644 (file)
index 0000000..578d046
--- /dev/null
@@ -0,0 +1,3 @@
+MD5 58cf989db6ca5b4db21fd4b45c09e66b catalyst-2.0.1.tar.bz2 782817
+RMD160 e504a767ac064e2410b1b24adbfda4bed4536582 catalyst-2.0.1.tar.bz2 782817
+SHA256 149548d37f9438b6fbbae06e61a74e80c908cb52a1d33c8fc33ec18a22157857 catalyst-2.0.1.tar.bz2 782817