www-apps/wordpress: bump to 5.4.1
authorMiroslav Šulc <fordfrog@gentoo.org>
Thu, 30 Apr 2020 04:59:32 +0000 (06:59 +0200)
committerMiroslav Šulc <fordfrog@gentoo.org>
Thu, 30 Apr 2020 04:59:32 +0000 (06:59 +0200)
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
www-apps/wordpress/Manifest
www-apps/wordpress/wordpress-5.4.1.ebuild [new file with mode: 0644]

index 1b077c6f81dcb468b9e352cd1c2c4de318987ec9..f279a7f954cc097693d9ed9d1f9af4a916fc78d5 100644 (file)
@@ -1 +1,2 @@
+DIST wordpress-5.4.1.tar.gz 12234700 BLAKE2B 0df1f1b1da22c5ad429ef59861dbcb80b5bd6c8720bc96b450d2b6599b903dda813e16f28fc2ee2afe1654b4047556a06bb409f6d0a3be3671b37e54fac52cf3 SHA512 5ed4f3bd593febdf2aec4c582c2ed850d3bf52122273b4306c1fba87939a675228df84092a709052f13e0096b2545cd6f078ab89b232ee4b4dce467d834de0cd
 DIST wordpress-5.4.tar.gz 12230487 BLAKE2B bced3e3eec1179b4c52190b24626632b3d0899f3dc33112374f316421ec6287b58d6c8684c85e743f5c92c2278e3e1408091dede6bacbc9b9be093350ed061c8 SHA512 0d2ae85bd0d0d1aeda6bc371d6357660233b604e46d764f2955abc88ccecd8bfb76f9b8d7fac788a3f8d9abb2a10b8ae60cee74ddcbe483136f0fd7ba0b842d8
diff --git a/www-apps/wordpress/wordpress-5.4.1.ebuild b/www-apps/wordpress/wordpress-5.4.1.ebuild
new file mode 100644 (file)
index 0000000..6fc0786
--- /dev/null
@@ -0,0 +1,57 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit webapp
+
+DESCRIPTION="Wordpress PHP and MySQL based content management system (CMS)"
+HOMEPAGE="https://wordpress.org/"
+SRC_URI="https://wordpress.org/${P/_rc/-RC}.tar.gz"
+
+LICENSE="GPL-2+"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc ~x86"
+
+RDEPEND="virtual/httpd-php
+       || ( dev-lang/php[mysql] dev-lang/php[mysqli] )"
+
+S=${WORKDIR}/${PN}
+
+need_httpd_cgi
+
+IUSE="+akismet examples +themes vhosts"
+
+src_install() {
+       webapp_src_preinst
+
+       dodoc readme.html
+       rm readme.html license.txt || die
+
+       if use !akismet ; then
+               rm -R wp-content/plugins/akismet/ || die
+       fi
+       if use !examples ; then
+               rm wp-content/plugins/hello.php || die
+       fi
+       if use !themes ; then
+               rm -R wp-content/themes/*/ || die
+       fi
+
+       [[ -f wp-config.php ]] || cp wp-config-sample.php wp-config.php
+
+       insinto "${MY_HTDOCSDIR}"
+       doins -r .
+
+       webapp_serverowned "${MY_HTDOCSDIR}"/index.php
+       webapp_serverowned "${MY_HTDOCSDIR}"/wp-admin/menu.php
+       webapp_serverowned "${MY_HTDOCSDIR}"
+       # allows plugins update if allowed within WP
+       webapp_serverowned "${MY_HTDOCSDIR}"/wp-admin/includes/file.php
+
+       webapp_configfile  "${MY_HTDOCSDIR}"/wp-config.php
+
+       webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
+       webapp_postupgrade_txt en "${FILESDIR}"/postupgrade-en.txt
+
+       webapp_src_install
+}