dev-python/pytest-forked: Remove old
authorMichał Górny <mgorny@gentoo.org>
Mon, 4 May 2020 11:43:38 +0000 (13:43 +0200)
committerMichał Górny <mgorny@gentoo.org>
Mon, 4 May 2020 11:43:38 +0000 (13:43 +0200)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/pytest-forked/Manifest
dev-python/pytest-forked/pytest-forked-0.2.ebuild [deleted file]

index 23d46b6cb660ba8259c1c9a0fa4dadc591aebd16..8cf2a4b0791fa535b1a333921c3f0fa8ce41fced 100644 (file)
@@ -1,2 +1 @@
-DIST pytest-forked-0.2.tar.gz 9617 BLAKE2B f306c968447b73ddd606f7929b730d222f30640544ff89f6e3e2171ec3b0e98877e0263fea6564d943789de6daa1c344022f001ef80ca37b2467c1b9c360eed7 SHA512 5e84fcaceed46ee9da8eec051e72acb46f09e2df3458511651604c35d68e3ad06fc41d52578127fd29f0c216dcb5fce1844c614f10501727cbf8fa8f2316f231
 DIST pytest-forked-1.1.3.tar.gz 7308 BLAKE2B 70711228a5a815de23cbd07b2b628e336a26ccecf420dc9d30d9e9b7ed33bc362b0ba74a8f90fb7cb8dc9e7e0f61d2ac22da55584a84e8ac3a26fcfc2878a802 SHA512 2086884b0e78841b3cdf8eb2b144b8fa60ba95e4be79bc58a2b5775a5f997dddef59377f7c993e54974fbbe13e73fe8688eed4d035e85293e35a143c5f0180f3
diff --git a/dev-python/pytest-forked/pytest-forked-0.2.ebuild b/dev-python/pytest-forked/pytest-forked-0.2.ebuild
deleted file mode 100644 (file)
index 946da6f..0000000
+++ /dev/null
@@ -1,38 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 python3_{6,7} pypy3 )
-
-inherit distutils-r1
-
-DESCRIPTION="run tests in isolated forked subprocesses"
-HOMEPAGE="https://pypi.org/project/pytest-forked/ https://github.com/pytest-dev/pytest-forked"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-SLOT="0"
-LICENSE="MIT"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~mips ppc ppc64 s390 sparc x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
-       >=dev-python/pytest-2.6.0[${PYTHON_USEDEP}]"
-
-DEPEND="
-       ${RDEPEND}
-       dev-python/setuptools[${PYTHON_USEDEP}]
-       dev-python/setuptools_scm[${PYTHON_USEDEP}]"
-
-python_prepare_all() {
-       distutils-r1_python_prepare_all
-
-       # remove bundled bytecode
-       rm -r testing/__pycache__ || die
-}
-
-python_test() {
-       distutils_install_for_testing
-       py.test -v || die "Tests failed under ${EPYTHON}"
-}