dev-python/sphinxcontrib-programoutput: version bump
authorSébastien Fabbro <bicatali@gentoo.org>
Wed, 2 Aug 2017 02:31:16 +0000 (02:31 +0000)
committerSébastien Fabbro <bicatali@gentoo.org>
Wed, 2 Aug 2017 04:06:25 +0000 (04:06 +0000)
Package-Manager: Portage-2.3.6, Repoman-2.3.3

dev-python/sphinxcontrib-programoutput/Manifest
dev-python/sphinxcontrib-programoutput/sphinxcontrib-programoutput-0.11.ebuild [new file with mode: 0644]

index 85bd1a09df40971bb0833d2957b7ae58711d6a1f..6f9de866d0ad746179c8b6bf4528a99258f06f03 100644 (file)
@@ -1 +1,2 @@
+DIST sphinxcontrib-programoutput-0.11.tar.gz 18267 SHA256 cbec3ee1c3abd09e105115ab69cb5ade8ca1be9811565a844f973e93e0314837 SHA512 4aa655f8632093035de986fa31291f95e95c4c0f4d1458bb8c8cc077cca73d579b16a8bf103d7b34faafb2171c617c40200008d89186f8ed37a812459f0376cf WHIRLPOOL 584b3c582217df7b24e08e27e0580d9af6f1f729ae823d4525ad7aa5105ca6048f4854928043231789f52f333cbc0a8a71a186b3d57b666d6e2a19249f750881
 DIST sphinxcontrib-programoutput-0.8.tar.gz 14419 SHA256 1776a03124bab87e35576f7f3992fc21d5bb457321b35e6023eb011dbed10a25 SHA512 9ab769f794cf8c47f2d755b343c1326b8335c1f8161294727abada81af189545d549350536d28ac2c5f27cc309330f875b7affef6f997651e3a9f9dfbe6bd174 WHIRLPOOL a6cf5edfd1ba9926af1327e95cc923147cae3c4d297ddb0ae7577f676c6bcb928b396459113cac3226f74446ea38ee9604722da5b4ddeebeb2f6bc6bc0d5fb52
diff --git a/dev-python/sphinxcontrib-programoutput/sphinxcontrib-programoutput-0.11.ebuild b/dev-python/sphinxcontrib-programoutput/sphinxcontrib-programoutput-0.11.ebuild
new file mode 100644 (file)
index 0000000..6920695
--- /dev/null
@@ -0,0 +1,44 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Extension to sphinx to include program output"
+HOMEPAGE="http://sphinxcontrib-programoutput.readthedocs.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+IUSE="doc test"
+
+RDEPEND="dev-python/sphinx[${PYTHON_USEDEP}]
+       dev-python/namespace-sphinxcontrib[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+       dev-python/setuptools[${PYTHON_USEDEP}]
+       test? (
+               dev-python/mock[${PYTHON_USEDEP}]
+               dev-python/pytest[${PYTHON_USEDEP}]
+       )"
+
+python_compile_all() {
+       if use doc; then
+               python_setup
+               esetup.py build_sphinx
+               HTML_DOCS=( "${BUILD_DIR}/sphinx/html/." )
+       fi
+}
+
+python_test() {
+       esetup.py pytest || die
+}
+
+python_install_all() {
+       distutils-r1_python_install_all
+       find "${ED}" -name '*.pth' -delete || die
+}