app-admin/abrt: remove old
authorMart Raudsepp <leio@gentoo.org>
Tue, 28 Jan 2020 09:06:38 +0000 (11:06 +0200)
committerMart Raudsepp <leio@gentoo.org>
Tue, 28 Jan 2020 09:34:17 +0000 (11:34 +0200)
Package-Manager: Portage-2.3.84, Repoman-2.3.20
Signed-off-by: Mart Raudsepp <leio@gentoo.org>
app-admin/abrt/Manifest
app-admin/abrt/abrt-2.10.10-r2.ebuild [deleted file]

index 3a2a0e6e70a4fc534eabd6be7bbbacb3cb4b4aed..5866ff387575f886e36c7ccff0da2d057209a9a1 100644 (file)
@@ -1,2 +1 @@
-DIST abrt-2.10.10.tar.gz 6830586 BLAKE2B 5cd45144678e6355cb1362c3ebe5531104bb150ff95c42d10e3056f7619cdc7dc3da57e4025cab05234866a4634f29bc07fd78f574800d6b303385c6befa25bd SHA512 6daeea898c9328d31b952ef12202162e002f91b4115301e5d66a0e6991251f9a8322b87201128f7efd54b42b76cb94abc4cf01e5d5b563f254f6757ec7e2127d
 DIST abrt-2.12.0.tar.gz 6799338 BLAKE2B 57a9b3fac4a4a5f55630be0573b26d4ae2d921d4f09d6566339a77f314c413c1a9e242f882fe20befabf30a58e7df21395edcf1b0d560bfeadf8e854bff6a705 SHA512 3567332399cd9708505a6d05c9388c7da5c14c7432e6fd40e5e76b6bcea8859c17b3b6c52a96ce54740e3682d75d8bf77dbc5fede80bd4fc6f72c60014f9cded
diff --git a/app-admin/abrt/abrt-2.10.10-r2.ebuild b/app-admin/abrt/abrt-2.10.10-r2.ebuild
deleted file mode 100644 (file)
index 17e113f..0000000
+++ /dev/null
@@ -1,116 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python3_6 )
-
-inherit autotools gnome2-utils python-single-r1 systemd user
-
-DESCRIPTION="Automatic bug detection and reporting tool"
-HOMEPAGE="https://github.com/abrt/abrt/wiki/ABRT-Project"
-SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 x86"
-
-IUSE="debug selinux"
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-COMMON_DEPEND="${PYTHON_DEPS}
-       >=dev-libs/glib-2.43:2
-       >=dev-libs/libreport-2.9.5[python]
-       dev-libs/libxml2
-       dev-libs/nss
-       >=gnome-base/gsettings-desktop-schemas-3.15.1
-       sys-apps/dbus
-       sys-apps/systemd
-       sys-auth/polkit
-       sys-fs/inotify-tools
-       x11-libs/gtk+:3
-       >=x11-libs/libnotify-0.7
-"
-RDEPEND="${COMMON_DEPEND}
-       app-arch/cpio
-       dev-libs/elfutils
-       dev-python/argcomplete[${PYTHON_USEDEP}]
-       dev-python/argh[${PYTHON_USEDEP}]
-       dev-python/humanize[${PYTHON_USEDEP}]
-       sys-apps/util-linux
-       >=sys-devel/gdb-7
-"
-DEPEND="${COMMON_DEPEND}
-       app-text/asciidoc
-       app-text/xmlto
-       dev-libs/satyr[${PYTHON_USEDEP}]
-       >=dev-util/intltool-0.35.0
-       virtual/pkgconfig
-       >=sys-devel/gettext-0.17
-"
-
-RESTRICT="test" # tests *may* be broken due to all the RHEL crap.  explore later.
-
-pkg_setup() {
-       python-single-r1_pkg_setup
-
-       enewgroup abrt
-       enewuser abrt -1 -1 -1 abrt
-}
-
-src_prepare() {
-       default
-
-       # pyhook test is sensitive to the format of python's error messages, and
-       # fails with certain python versions
-       sed -e '/pyhook.at/ d' \
-               -i tests/Makefile.* tests/testsuite.at || die "sed remove pyhook tests failed"
-       ./gen-version || die # Needed to be run before autoreconf
-       eautoreconf
-}
-
-src_configure() {
-       myeconfargs=(
-               --libdir="${EPREFIX}/usr/$(get_libdir)"
-               --localstatedir="${EPREFIX}/var"
-               --without-bodhi
-               # package breaks due to not finding libreport-web with bodhi plugin enabled
-               --without-rpm
-               $(usex selinux "" "--without-selinux")
-               --without-python2
-               # Fixes "syntax error in VERSION script" and we aren't supporting Python2 anyway
-               --with-python3
-               --without-pythondoc
-               # package breaks due to no sphinx-build-3
-               --without-pythontests
-               # kill tests for now until they can be explored.
-       )
-
-       econf "${myeconfargs[@]}"
-}
-
-src_install() {
-       default
-       python_optimize #661706
-
-       keepdir /var/run/abrt
-       # /var/spool/abrt is created by dev-libs/libreport
-
-       diropts -m 700 -o abrt -g abrt
-       keepdir /var/spool/abrt-upload
-
-       diropts -m 775 -o abrt -g abrt
-       keepdir /var/cache/abrt-di
-
-       find "${D}" -name '*.la' -delete || die
-
-       newinitd "${FILESDIR}/${PN}-2.0.12-r1-init" abrt
-       newconfd "${FILESDIR}/${PN}-2.0.12-r1-conf" abrt
-}
-
-pkg_postinst() {
-       gnome2_icon_cache_update
-}
-
-pkg_postrm() {
-       gnome2_icon_cache_update
-}