dev-python/extras: Add pypy3 support
authorJustin Lecher <jlec@gentoo.org>
Sun, 23 Aug 2015 17:53:47 +0000 (19:53 +0200)
committerJustin Lecher <jlec@gentoo.org>
Mon, 24 Aug 2015 10:12:04 +0000 (12:12 +0200)
Package-Manager: portage-2.2.20.1
Signed-off-by: Justin Lecher <jlec@gentoo.org>
dev-python/extras/extras-0.0.3.ebuild

index d066a64c0dd56e2861a16cb0351a574a3cdf39ed..0dab6721b70c92023ab80ee7bb7c5095668c3bde 100644 (file)
@@ -3,7 +3,8 @@
 # $Id$
 
 EAPI=5
-PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy pypy3 )
 
 inherit distutils-r1
 
@@ -16,11 +17,11 @@ SLOT="0"
 KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~mips ppc ppc64 sparc x86 ~amd64-fbsd ~x86-fbsd"
 IUSE="test"
 
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+DEPEND="
+       dev-python/setuptools[${PYTHON_USEDEP}]
        test? ( dev-python/testtools[${PYTHON_USEDEP}] )"
 RDEPEND=""
 
 python_test() {
        "${PYTHON}" ${PN}/tests/test_extras.py || die
-       einfo "test_extras passed under ${EPYTHON}"
 }