dev-python/tinycss: Enable py3.{7,8}
authorMichał Górny <mgorny@gentoo.org>
Sun, 26 Apr 2020 12:35:54 +0000 (14:35 +0200)
committerMichał Górny <mgorny@gentoo.org>
Sun, 26 Apr 2020 12:50:55 +0000 (14:50 +0200)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/tinycss/tinycss-0.4.ebuild

index 61c40e7cfbc0c08417789cfa420eab58f6f58eb9..f69dee9435d3681b24d6b49ae2644f3f9980840c 100644 (file)
@@ -3,7 +3,7 @@
 
 EAPI=6
 
-PYTHON_COMPAT=( python{2_7,3_6} )
+PYTHON_COMPAT=( python{2_7,3_{6,7,8}} )
 
 inherit distutils-r1
 
@@ -32,8 +32,5 @@ python_prepare_all() {
 
 python_test() {
        export TINYCSS_SKIP_SPEEDUPS_TESTS=1
-       local test
-       for test in ${PN}/tests/test_*.py; do
-               py.test $test || die
-       done
+       pytest -vv ${PN}/tests/test_*.py || die
 }