media-libs/libfishsound: EAPI-7 bump, sort deps, fix description
authorAndreas Sturmlechner <asturm@gentoo.org>
Sat, 18 Aug 2018 08:25:10 +0000 (10:25 +0200)
committerAndreas Sturmlechner <asturm@gentoo.org>
Sat, 18 Aug 2018 08:25:50 +0000 (10:25 +0200)
Thanks-to: Michael Mair-Keimberger (iamnr3) <bu9zilla@gmail.com>
Closes: https://bugs.gentoo.org/663800
Closes: https://github.com/gentoo/gentoo/pull/9032

media-libs/libfishsound/files/libfishsound-1.0.0-pc.patch
media-libs/libfishsound/libfishsound-1.0.0.ebuild

index fa417bb98ef85d45b47a915933597e37578b8ce5..fae476bf8e2654a4dc6336d055a31bd5539dcd9b 100644 (file)
@@ -1,8 +1,8 @@
 This will avoid including -I/usr/include/FLAC in `pkg-config --cflags fishsound` since
 FLAC/assert.h will collide with system assert.h.
 
---- fishsound.pc.in
-+++ fishsound.pc.in
+--- a/fishsound.pc.in
++++ b/fishsound.pc.in
 @@ -5,7 +5,6 @@
  
  Name: fishsound
index e67184a6f17c52c904f7b060d01307d9c6c45b99..d5fe387728b877138edc050496aa1def7d80b7e7 100644 (file)
@@ -1,20 +1,20 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=2
-inherit eutils
+EAPI=7
 
-DESCRIPTION="Simple programming interface for decoding and encoding audio data using vorbis or speex"
-HOMEPAGE="http://www.xiph.org/fishsound/"
-SRC_URI="http://downloads.xiph.org/releases/libfishsound/${P}.tar.gz"
+DESCRIPTION="Simple programming interface to decode and encode audio with vorbis or speex"
+HOMEPAGE="https://www.xiph.org/fishsound/"
+SRC_URI="https://downloads.xiph.org/releases/libfishsound/${P}.tar.gz"
 
 LICENSE="BSD"
 SLOT="0"
 KEYWORDS="amd64 x86"
 IUSE="flac speex"
 
-RDEPEND="media-libs/libvorbis
+RDEPEND="
        media-libs/libogg
+       media-libs/libvorbis
        flac? ( media-libs/flac )
        speex? ( media-libs/speex )"
 DEPEND="${RDEPEND}
@@ -23,8 +23,10 @@ DEPEND="${RDEPEND}
 # bug #395153
 RESTRICT="test"
 
+PATCHES=( "${FILESDIR}"/${P}-pc.patch )
+
 src_prepare() {
-       epatch "${FILESDIR}"/${P}-pc.patch
+       default
        sed -i \
                -e 's:doxygen:doxygen-dummy:' \
                configure || die
@@ -42,6 +44,6 @@ src_configure() {
 
 src_install() {
        emake DESTDIR="${D}" \
-               docdir="${D}/usr/share/doc/${PF}" install || die
+               docdir="${D}/usr/share/doc/${PF}" install
        dodoc AUTHORS ChangeLog README
 }