dev-python/pypy3: Use usession*-0 rather than -current
authorMichał Górny <mgorny@gentoo.org>
Fri, 7 Apr 2017 19:58:54 +0000 (21:58 +0200)
committerMichał Górny <mgorny@gentoo.org>
Sat, 8 Apr 2017 05:42:40 +0000 (07:42 +0200)
Use the usession*-0 directory directly rather than relying on the
usession*-current symlink. As maffblaster reports, under some
circumstances the symlink is called differently which seems to render
the -0 name safer.

dev-python/pypy3/pypy3-5.5.0_alpha.ebuild
dev-python/pypy3/pypy3-9999.ebuild

index 1a43699143622cde813cca5c9eb147314cc3919a..3c4ac7df716febc362e808ed8577d4d14dce5ba7 100644 (file)
@@ -160,10 +160,10 @@ src_configure() {
 }
 
 src_compile() {
-       emake -C "${T}"/usession*-current/testing_1
+       emake -C "${T}"/usession*-0/testing_1
 
        # copy back to make sys.prefix happy
-       cp -p "${T}"/usession*-current/testing_1/{pypy-c,libpypy-c.so} . || die
+       cp -p "${T}"/usession*-0/testing_1/{pypy-c,libpypy-c.so} . || die
        pax-mark m pypy-c libpypy-c.so
 
        #use doc && emake -C pypy/doc html
index b399af1a9d49a7e47feed9c5a0455ead08f49002..8c0e93878b20fe89f8ba16c8c1104b9d45c00740 100644 (file)
@@ -169,10 +169,10 @@ src_configure() {
 }
 
 src_compile() {
-       emake -C "${T}"/usession*-current/testing_1
+       emake -C "${T}"/usession*-0/testing_1
 
        # copy back to make sys.prefix happy
-       cp -p "${T}"/usession*-current/testing_1/{pypy-c,libpypy-c.so} . || die
+       cp -p "${T}"/usession*-0/testing_1/{pypy-c,libpypy-c.so} . || die
        pax-mark m pypy-c libpypy-c.so
 
        #use doc && emake -C pypy/doc html