dev-lua/lua-argparse: command line parser for Lua (new package)
authorVictor Payno <vpayno+gentoo@gmail.com>
Fri, 24 Jan 2020 22:18:23 +0000 (14:18 -0800)
committerGeorgy Yakovlev <gyakovlev@gentoo.org>
Sat, 14 Mar 2020 23:35:08 +0000 (16:35 -0700)
Signed-off-by: Victor Payno <vpayno+gentoo@gmail.com>
Argparse is a feature-rich command line parser for Lua inspired by argparse for Python.
Closes: https://github.com/gentoo/gentoo/pull/14435

Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
dev-lua/lua-argparse/Manifest [new file with mode: 0644]
dev-lua/lua-argparse/lua-argparse-0.6.0.ebuild [new file with mode: 0644]
dev-lua/lua-argparse/metadata.xml [new file with mode: 0644]

diff --git a/dev-lua/lua-argparse/Manifest b/dev-lua/lua-argparse/Manifest
new file mode 100644 (file)
index 0000000..2adc19a
--- /dev/null
@@ -0,0 +1 @@
+DIST lua-argparse-0.6.0.tar.gz 36712 BLAKE2B 88882738453a894db68ef93557d870393eaec1fb2bf39b110bd2691678d26be64734d07c7f01f760d9c1d031e530707449ff2ca54a5cdd428cb8da3b1897a7e1 SHA512 7efdfab8ec563a9e7eddc7aff760fd4d3605df2896939af3f2c80e5ed4d4e5ba45a7815057e15446d242351a6fd139d6b8da802fe318d4a4bcd69918fece53d1
diff --git a/dev-lua/lua-argparse/lua-argparse-0.6.0.ebuild b/dev-lua/lua-argparse/lua-argparse-0.6.0.ebuild
new file mode 100644 (file)
index 0000000..49f8111
--- /dev/null
@@ -0,0 +1,53 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit toolchain-funcs
+
+DESCRIPTION="Command line argument parser for the Lua Programming Language"
+HOMEPAGE="https://github.com/mpeterv/argparse"
+SRC_URI="https://github.com/mpeterv/argparse/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="doc luajit test"
+
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+       >=dev-lang/lua-5.1:=
+       luajit? ( dev-lang/luajit:2 )"
+BDEPEND="
+       virtual/pkgconfig
+       doc? ( dev-python/sphinx )
+       test? (
+               ${RDEPEND}
+               dev-lua/busted
+       )"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${PN//lua-/}-${PV}"
+
+src_compile() {
+       if use doc; then
+               sphinx-build docsrc html || die
+               rm -rf "${S}"/html/{.doctrees,_sources} || die
+       fi
+}
+
+src_test() {
+       busted -o gtest || die
+}
+
+src_install() {
+       use doc && local -a HTML_DOCS=( html/. )
+       local -a DOCS=( README.md CHANGELOG.md )
+       einstalldocs
+
+       local instdir
+       instdir="$($(tc-getPKG_CONFIG) --variable INSTALL_LMOD $(usex luajit 'luajit' 'lua'))"/${PN}
+
+       insinto "${instdir#${EPREFIX}}"
+       doins src/argparse.lua
+}
diff --git a/dev-lua/lua-argparse/metadata.xml b/dev-lua/lua-argparse/metadata.xml
new file mode 100644 (file)
index 0000000..3af6201
--- /dev/null
@@ -0,0 +1,21 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+       <maintainer type="person">
+               <email>vpayno+gentoo@gmail.com</email>
+               <name>Victor Payno</name>
+       </maintainer>
+       <maintainer type="person">
+               <email>gyakovlev@gentoo.org</email>
+               <name>Georgy Yakovlev</name>
+       </maintainer>
+       <longdescription lang="en">
+               Argparse is a feature-rich command line parser for Lua inspired by argparse for Python.
+
+               Argparse supports positional arguments, options, flags, optional arguments, subcommands
+               and more. Argparse automatically generates usage, help and error messages.
+       </longdescription>
+       <upstream>
+               <remote-id type="github">mpeterv/argparse</remote-id>
+       </upstream>
+</pkgmetadata>