media-libs/mesa: Drop IUSE=pax_kernel
authorMatt Turner <mattst88@gentoo.org>
Thu, 5 Dec 2019 23:07:56 +0000 (18:07 -0500)
committerMatt Turner <mattst88@gentoo.org>
Thu, 5 Dec 2019 23:20:38 +0000 (18:20 -0500)
Signed-off-by: Matt Turner <mattst88@gentoo.org>
media-libs/mesa/mesa-9999.ebuild

index 89ebb55245dd6f65623262ed924a8852c97620ac..db1fd34bf9abc3a6f29014fa21788d2b56728eb6 100644 (file)
@@ -36,8 +36,8 @@ done
 
 IUSE="${IUSE_VIDEO_CARDS}
        +classic d3d9 debug +dri3 +egl +gallium +gbm gles1 +gles2 libglvnd +llvm
-       lm-sensors opencl osmesa pax_kernel selinux test unwind vaapi valgrind
-       vdpau vulkan vulkan-overlay wayland +X xa xvmc"
+       lm-sensors opencl osmesa selinux test unwind vaapi valgrind vdpau vulkan
+       vulkan-overlay wayland +X xa xvmc"
 
 REQUIRED_USE="
        d3d9?   ( dri3 || ( video_cards_iris video_cards_r300 video_cards_r600 video_cards_radeonsi video_cards_nouveau video_cards_vmware ) )
@@ -458,11 +458,6 @@ multilib_src_configure() {
                vulkan_enable video_cards_radeonsi amd
        fi
 
-       # x86 hardened pax_kernel needs glx-rts, bug 240956
-       if [[ ${ABI} == x86 ]]; then
-               emesonargs+=( $(meson_use pax_kernel glx-read-only-text) )
-       fi
-
        if use gallium; then
                gallium_enable -- swrast
                emesonargs+=( -Dosmesa=$(usex osmesa gallium none) )