dev-lang/php: add missing RESTRICT
authorThomas Deutschmann <whissi@gentoo.org>
Mon, 11 Nov 2019 19:37:15 +0000 (20:37 +0100)
committerThomas Deutschmann <whissi@gentoo.org>
Mon, 11 Nov 2019 20:31:23 +0000 (21:31 +0100)
Package-Manager: Portage-2.3.79, Repoman-2.3.18
Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
dev-lang/php/php-7.4.0_rc6.ebuild

index ececc5cc430e3f37ba3e14cb3b67fc73bc60a978..20df8781da5ae63c2e9036437e4d749d66dffe5f 100644 (file)
@@ -45,6 +45,33 @@ IUSE="${IUSE} acl argon2 bcmath berkdb bzip2 calendar cdb cjk
        sysvipc systemd test tidy +tokenizer tokyocabinet truetype unicode webp
        +xml xmlreader xmlwriter xmlrpc xpm xslt zip zlib"
 
+# Without USE=readline or libedit, the interactive "php -a" CLI will hang.
+REQUIRED_USE="
+       || ( cli cgi fpm apache2 embed phpdbg )
+       cli? ( ^^ ( readline libedit ) )
+       !cli? ( ?? ( readline libedit ) )
+       truetype? ( gd zlib )
+       webp? ( gd zlib )
+       cjk? ( gd zlib )
+       exif? ( gd zlib )
+       xpm? ( gd zlib )
+       gd? ( zlib )
+       simplexml? ( xml )
+       soap? ( xml )
+       xmlrpc? ( xml iconv )
+       xmlreader? ( xml )
+       xmlwriter? ( xml )
+       xslt? ( xml )
+       ldap-sasl? ( ldap )
+       qdbm? ( !gdbm )
+       session-mm? ( session !threads )
+       mysql? ( || ( mysqli pdo ) )
+       firebird? ( pdo )
+       mssql? ( pdo )
+"
+
+RESTRICT="!test? ( test )"
+
 # The supported (that is, autodetected) versions of BDB are listed in
 # the ./configure script. Other versions *work*, but we need to stick to
 # the ones that can be detected to avoid a repeat of bug #564824.
@@ -121,31 +148,6 @@ DEPEND="${COMMON_DEPEND}
 
 BDEPEND="virtual/pkgconfig"
 
-# Without USE=readline or libedit, the interactive "php -a" CLI will hang.
-REQUIRED_USE="
-       || ( cli cgi fpm apache2 embed phpdbg )
-       cli? ( ^^ ( readline libedit ) )
-       !cli? ( ?? ( readline libedit ) )
-       truetype? ( gd zlib )
-       webp? ( gd zlib )
-       cjk? ( gd zlib )
-       exif? ( gd zlib )
-       xpm? ( gd zlib )
-       gd? ( zlib )
-       simplexml? ( xml )
-       soap? ( xml )
-       xmlrpc? ( xml iconv )
-       xmlreader? ( xml )
-       xmlwriter? ( xml )
-       xslt? ( xml )
-       ldap-sasl? ( ldap )
-       qdbm? ( !gdbm )
-       session-mm? ( session !threads )
-       mysql? ( || ( mysqli pdo ) )
-       firebird? ( pdo )
-       mssql? ( pdo )
-"
-
 PHP_MV="$(ver_cut 1)"
 
 php_install_ini() {