dev-python/entrypoints: Replace virts with cond deps
authorMichał Górny <mgorny@gentoo.org>
Mon, 16 Mar 2020 21:03:10 +0000 (22:03 +0100)
committerMichał Górny <mgorny@gentoo.org>
Mon, 16 Mar 2020 21:09:36 +0000 (22:09 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/entrypoints/entrypoints-0.3-r1.ebuild

index 0b64e872fe36650920761c2766343fa46ffe6fe1..0eb427f32fa5666e49ecd4c45e25c99f074c3c1e 100644 (file)
@@ -19,13 +19,15 @@ IUSE="test"
 RESTRICT="!test? ( test )"
 
 RDEPEND="
-       $(python_gen_cond_dep '>=dev-python/configparser-3.5.0[${PYTHON_USEDEP}]' 'python2*')
+       $(python_gen_cond_dep '>=dev-python/configparser-3.5.0[${PYTHON_USEDEP}]' -2)
 "
 BDEPEND="
        test? (
                ${RDEPEND}
                dev-python/pytest[${PYTHON_USEDEP}]
-               virtual/python-pathlib[${PYTHON_USEDEP}]
+               $(python_gen_cond_dep '
+                       dev-python/pathlib[${PYTHON_USEDEP}]
+               ' -2)
        )
 "