games-puzzle/swell-foop: add swell-foop-3.22.2.ebuild
authorChristophe Lermytte <gentoo@lermytte.be>
Tue, 8 Nov 2016 22:18:32 +0000 (23:18 +0100)
committerGilles Dartiguelongue <eva@gentoo.org>
Wed, 9 Nov 2016 23:27:34 +0000 (00:27 +0100)
Simple bump, no relevant changes

https://git.gnome.org/browse/swell-foop/diff/?id=3.22.2&&id2=3.22.0
Closes: https://github.com/gentoo/gentoo/pull/2785

Signed-off-by: Gilles Dartiguelongue <eva@gentoo.org>
games-puzzle/swell-foop/Manifest
games-puzzle/swell-foop/swell-foop-3.22.2.ebuild [new file with mode: 0644]

index 6f6fdb8a7a302d67fea822718a0c8b41efcdd924..88f4aba7ab0b81248f7d378f6d8a66d452c3860d 100644 (file)
@@ -1,2 +1,3 @@
 DIST swell-foop-3.20.0.tar.xz 2310976 SHA256 40532a734dcae6d42a1e4692fd94e395442ff07c134acacf5fce3396c1e352a4 SHA512 522c39eb906701d9e849442e62b27e8aa1072d79bb7f4d4216eeb7e436c46a2b252575fa399416bfd9cc18469797e15096e426fd3ffd68111cc213f0307ac413 WHIRLPOOL e3d37f840259e85bf1ffb7054e8b27cd4e86daf4b2701a442c9f4e29f68b9fdfc4a3bec0376a1a0aad40f616c6dca3d833bf4a145dffb65d8a50a63e6105013e
 DIST swell-foop-3.22.0.tar.xz 1633280 SHA256 e7bb6f4c7932a17c3f48e5b7df66f4e3953642e8126389531592a79fdf71e0a4 SHA512 8b6b3f3b297da1246b0d04ac7d08d9b0fbcd09ad84a84b33c5235f4021cc312052f4554acbc6b49d67091e018dfb9ffd8523d43201c19f2255b1d7da99473379 WHIRLPOOL 04901596ba84ef023004f15e666790dadae10268a50c407865567e410b9afcc09c94750111d2d4c4a177e3f68e06edc33103b82cb80ecb4ac44ffe80387ba04b
+DIST swell-foop-3.22.2.tar.xz 2294160 SHA256 6e0fedc98fb1191779db2de04cfa950357e81e3191164006412b09ad2ef64e67 SHA512 ada002a883c274cd834db825879cd5c16b222df39212843b0718f953256838af8689bec10a02133dcb140f3567b1a9203c73e1e0c6530469630df6dfdaf7167f WHIRLPOOL fe55c56770889759fdabd3b46746dbf723e4a06625e7e2a1b649be137e45b05431002558a9f48e2f1ecc942d154b157e004eabde0b9d0117671dcc6c01b4cbd5
diff --git a/games-puzzle/swell-foop/swell-foop-3.22.2.ebuild b/games-puzzle/swell-foop/swell-foop-3.22.2.ebuild
new file mode 100644 (file)
index 0000000..6a0b678
--- /dev/null
@@ -0,0 +1,34 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit gnome2 vala
+
+DESCRIPTION="Clear the screen by removing groups of colored and shaped tiles"
+HOMEPAGE="https://wiki.gnome.org/Apps/Swell%20Foop"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+RDEPEND="
+       >=dev-libs/glib-2.36:2
+       >=media-libs/clutter-1.14:1.0
+       >=media-libs/clutter-gtk-1.5:1.0
+       >=x11-libs/gtk+-3.12:3
+"
+DEPEND="${RDEPEND}
+       $(vala_depend)
+       app-text/yelp-tools
+       dev-libs/appstream-glib
+       >=dev-util/intltool-0.50
+       sys-devel/gettext
+       virtual/pkgconfig
+"
+
+src_prepare() {
+       gnome2_src_prepare
+       vala_src_prepare
+}