dev-vcs/svn2cl: bump EAPI and stuff
authorAaron Bauman <bman@gentoo.org>
Sun, 10 Nov 2019 03:19:09 +0000 (22:19 -0500)
committerAaron Bauman <bman@gentoo.org>
Sun, 10 Nov 2019 03:19:09 +0000 (22:19 -0500)
Signed-off-by: Aaron Bauman <bman@gentoo.org>
dev-vcs/svn2cl/files/0.9-wrapper.patch
dev-vcs/svn2cl/svn2cl-0.12.ebuild

index 478b2a032d2a9af23e7556b4ebe70b8e92e46807..3b06c36b6a09ca48543085fb8338ef5d6ccaf706 100644 (file)
@@ -1,5 +1,5 @@
---- svn2cl.sh  2006-10-18 23:38:06.000000000 +0200
-+++ svn2cl.sh.1        2006-11-12 01:41:05.000000000 +0100
+--- a/svn2cl.sh        2006-10-18 23:38:06.000000000 +0200
++++ b/svn2cl.sh        2006-11-12 01:41:05.000000000 +0100
 @@ -234,16 +234,7 @@
    esac
  done
index 1591242a706962e46bf6b3036486be9c37c74ba7..d788d5b194c9c3304f9b93367fdd83d857a8cf02 100644 (file)
@@ -1,13 +1,11 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=0
-
-inherit eutils
+EAPI=7
 
 DESCRIPTION="Create a GNU-style ChangeLog from subversion's svn log --xml output"
-HOMEPAGE="http://ch.tudelft.nl/~arthur/svn2cl/"
-SRC_URI="${HOMEPAGE}/${P}.tar.gz"
+HOMEPAGE="https://arthurdejong.org/svn2cl/"
+SRC_URI="https://arthurdejong.org/svn2cl/${P}.tar.gz"
 
 LICENSE="BSD"
 SLOT="0"
@@ -17,20 +15,14 @@ IUSE=""
 RDEPEND="dev-libs/libxslt
        dev-vcs/subversion"
 
-src_unpack() {
-       unpack ${A}
-       cd "${S}"
-       # the wrapper script looks for the xsl files in the
-       # same directory as the script.
-       epatch "${FILESDIR}"/0.9-wrapper.patch
-}
+PATCHES=( "${FILESDIR}/0.9-wrapper.patch" )
 
 src_install() {
-       newbin svn2cl.sh svn2cl || die "failed to install wrapper script"
+       newbin svn2cl.sh svn2cl
        insinto /usr/share/svn2cl
-       doins svn2cl.xsl svn2html.xsl || die
-       dodoc README NEWS TODO ChangeLog authors.xml svn2html.css || die
-       doman svn2cl.1 || die
+       doins svn2cl.xsl svn2html.xsl
+       dodoc README NEWS TODO ChangeLog authors.xml svn2html.css
+       doman svn2cl.1
 }
 
 pkg_postinst() {