per bug 204468, remove old check from repoman (all ebuilds in
authorZac Medico <zmedico@gentoo.org>
Fri, 11 Jan 2008 05:33:52 +0000 (05:33 -0000)
committerZac Medico <zmedico@gentoo.org>
Fri, 11 Jan 2008 05:33:52 +0000 (05:33 -0000)
gentoo-x86 are migrated). (trunk r9144)

svn path=/main/branches/2.1.2/; revision=9168

bin/repoman

index b4b64827140a87e845533396941971e7914376d3..738746e6738db40545a58a78798bdf64e7e09a84 100755 (executable)
@@ -909,27 +909,6 @@ else:
        #this can be problematic if xmllint changes their output
        xmllint_capable=True
 
-
-def x11_deprecation_check(depstr):
-       if depstr.find("virtual/x11") == -1:
-               return False
-       depsplit = depstr.split()
-       ok_stack = []
-       ok = False
-       for token in depsplit:
-               if token == "(":
-                       ok_stack.append(ok)
-                       ok = False
-               elif token == ")":
-                       ok = ok_stack.pop()
-               elif token == "||":
-                       ok = True
-               else:
-                       ok = False
-                       if token.find("virtual/x11") != -1 and (not ok_stack or not ok_stack[-1]):
-                               return True
-       return False
-
 MISSING_QUOTES_ERROR = 'Unquoted Variable on line: %d'
 NESTED_DIE_ERROR = 'Ebuild calls die in a subshell on line: %d'
 REDUNDANT_CD_S_ERROR = 'Ebuild has redundant cd ${S} statement on line: %d'
@@ -1606,11 +1585,6 @@ for x in scanlist:
                badlicsyntax = badlicsyntax > 0
                badprovsyntax = badprovsyntax > 0
 
-               if not baddepsyntax:
-                       if x11_deprecation_check(" ".join([myaux["DEPEND"], myaux["RDEPEND"], myaux["PDEPEND"]])):
-                               stats["usage.obsolete"] += 1
-                               fails["usage.obsolete"].append("%s/%s.ebuild: not migrated to modular X" % (x, y))
-
                # uselist checks - global
                myuse = []
                default_use = []