net-misc/gns3-gui: Bump to version 2.1.21
authorGino McCarty <onigino@protonmail.com>
Tue, 23 Apr 2019 20:15:02 +0000 (13:15 -0700)
committerMichał Górny <mgorny@gentoo.org>
Tue, 16 Jul 2019 12:12:51 +0000 (14:12 +0200)
Signed-off-by: Gino McCarty <onigino@protonmail.com>
Signed-off-by: Michał Górny <mgorny@gentoo.org>
net-misc/gns3-gui/Manifest
net-misc/gns3-gui/gns3-gui-2.1.21.ebuild [new file with mode: 0644]

index 21ceab7d5dbe46da01fdeadb4314726e18965811..c715e4cbf9d6fcfc66b5e2079d2142eed61a06dd 100644 (file)
@@ -1 +1,2 @@
+DIST gns3-gui-2.1.21.tar.gz 4845512 BLAKE2B 93af250719a0aafe8645926552c61d43152e5a5620d42b4d73cd58d597b3280d11935043771f15cf04e5d116f6740d929e04c27b1af6732d65b7c6e36313ed3c SHA512 b9b03c59064214323fe7375256075c56368747c8cd273bea41791b101ea7d6b877443e81dd57f13faf4b4bdc6de558e98648770de4734b1edd1c82911f2fcb9b
 DIST gns3-gui-2.1.3.tar.gz 4792762 BLAKE2B 577381bdee06f967e4fddec3b0885920e8a25380d834ab1c983e010d40a14f63c69912f745bb72b4605e49cdf7192fe52ac57380d5f65f03d067a2f1dd03f7d6 SHA512 da90eea0920f9fc10bb5ea7e0039ca11bfaf36870e182a6b97ffdbab9f12da0d13b58c4a13ca747add675426324f3c1cde5eedbd858a68ee4bbefdcdff193904
diff --git a/net-misc/gns3-gui/gns3-gui-2.1.21.ebuild b/net-misc/gns3-gui/gns3-gui-2.1.21.ebuild
new file mode 100644 (file)
index 0000000..f2fd83a
--- /dev/null
@@ -0,0 +1,34 @@
+# Copyright 1999-2019 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{5,6} )
+
+inherit distutils-r1 desktop
+
+DESCRIPTION="Graphical Network Simulator"
+HOMEPAGE="http://www.gns3.net/"
+SRC_URI="https://github.com/GNS3/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+#net-misc/gns3-server version should always match gns3-gui version
+
+RDEPEND="
+       >=dev-python/jsonschema-2.6.0[${PYTHON_USEDEP}]
+       >=dev-python/raven-5.23.0[${PYTHON_USEDEP}]
+       >=dev-python/psutil-2.2.1[${PYTHON_USEDEP}]
+       ~net-misc/gns3-server-${PV}[${PYTHON_USEDEP}]
+       dev-python/PyQt5[gui,network,svg,websockets,widgets,${PYTHON_USEDEP}]
+"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_install_all() {
+       distutils-r1_python_install_all
+
+       doicon "resources/images/gns3.ico"
+       make_desktop_entry "gns3" "GNS3" "gns3.ico" "Utility"
+}