net-misc/smb4k: 3.0.1 version bump
authorAndreas Sturmlechner <asturm@gentoo.org>
Thu, 20 Jun 2019 13:42:56 +0000 (15:42 +0200)
committerAndreas Sturmlechner <asturm@gentoo.org>
Thu, 20 Jun 2019 13:42:56 +0000 (15:42 +0200)
This is basically same as 3.0.0-r1.

Package-Manager: Portage-2.3.67, Repoman-2.3.15
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
net-misc/smb4k/Manifest
net-misc/smb4k/smb4k-3.0.1.ebuild [new file with mode: 0644]

index 89cb892e3efa3295dda3223842a68854d420b709..b51868bcbffc2f70fd20acf14973051a77a2620f 100644 (file)
@@ -1,2 +1,3 @@
 DIST smb4k-2.1.1.tar.xz 3718220 BLAKE2B 99258ac57d3b8ff2861b8635b6a0799a347f3934c8d070d41c09f49b69caa7b59f502db9041d1bc4f875ae15544254faaafaae6429200ddf5526a06812983e1f SHA512 d69cb9f4c22e2afdd111e73c3d99d6868f959aa5476ffe10620862d3659b5a4f3b814856b17a9dced7bf6dde524f5bcf224e62d413d2aa92b0bcc2272ddf22b7
 DIST smb4k-3.0.0.tar.xz 3825920 BLAKE2B 5439caa8f02fc93cd2065384e2b502abdca328fd186cb10ac0837d7eb289a2d62bedd81439a6d5b0e815edfb7fe168fcb70f0e645f3bae2d39a391d0688487f6 SHA512 b32a7151adb46b93e2c245136752435d3842e135baeb2b44343287d2eaf9f2aa5622a28b19df7d821390a35994f3ce204fdf20aeeac6ad67e9eb3b144ee22e33
+DIST smb4k-3.0.1.tar.xz 3826160 BLAKE2B e42d761d67ae6b25e75fc673eb18838607dc36d5c76d4cba63257d09c2e138fcc3b1e3600163188117a020327645b7fe320d4a25f7455f2585cdbcf567e3d941 SHA512 de61d7dc2f63657056d721ac5ef5c12e8c8393b674163c2888a63a58f5779b0efcc47c2acaee782979c4bd9abc008eb457b6fce31d085b3e80c0970a195528b9
diff --git a/net-misc/smb4k/smb4k-3.0.1.ebuild b/net-misc/smb4k/smb4k-3.0.1.ebuild
new file mode 100644 (file)
index 0000000..896232b
--- /dev/null
@@ -0,0 +1,68 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+KDE_HANDBOOK="forceoptional"
+inherit kde5
+
+DESCRIPTION="Advanced network neighborhood browser"
+HOMEPAGE="https://sourceforge.net/p/smb4k/home/Home/"
+
+if [[ ${KDE_BUILD_TYPE} = release ]]; then
+       SRC_URI="mirror://sourceforge/${PN}/${P}.tar.xz"
+       KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-2"
+IUSE="plasma"
+
+DEPEND="
+       $(add_frameworks_dep kauth)
+       $(add_frameworks_dep kcompletion)
+       $(add_frameworks_dep kconfig)
+       $(add_frameworks_dep kconfigwidgets)
+       $(add_frameworks_dep kcoreaddons)
+       $(add_frameworks_dep kcrash)
+       $(add_frameworks_dep kdbusaddons)
+       $(add_frameworks_dep ki18n)
+       $(add_frameworks_dep kiconthemes)
+       $(add_frameworks_dep kio)
+       $(add_frameworks_dep kjobwidgets)
+       $(add_frameworks_dep knotifications)
+       $(add_frameworks_dep kwallet)
+       $(add_frameworks_dep kwidgetsaddons)
+       $(add_frameworks_dep kwindowsystem)
+       $(add_frameworks_dep kxmlgui)
+       $(add_frameworks_dep solid)
+       $(add_qt_dep qtdeclarative)
+       $(add_qt_dep qtgui)
+       $(add_qt_dep qtnetwork)
+       $(add_qt_dep qtprintsupport)
+       $(add_qt_dep qttest)
+       $(add_qt_dep qtwidgets)
+       net-fs/samba[cups]
+"
+RDEPEND="${DEPEND}
+       plasma? (
+               $(add_frameworks_dep plasma)
+               $(add_qt_dep qtquickcontrols2)
+       )
+"
+
+src_configure(){
+       local mycmakeargs=(
+               -DINSTALL_PLASMOID=$(usex plasma)
+       )
+       kde5_src_configure
+}
+
+pkg_postinst() {
+       kde5_pkg_postinst
+       elog "Users of Samba 4.7 and above please note that for the time being,"
+       elog "the following setting has to be added to or changed in the [global]"
+       elog "section of the smb.conf file:"
+       elog
+       elog "[global]"
+       elog "client max protocol = NT1"
+}