app-editors/aee: fix build with >=sys-devel/gcc-10
authorAkinori Hattori <hattya@gentoo.org>
Sun, 10 May 2020 09:38:53 +0000 (18:38 +0900)
committerAkinori Hattori <hattya@gentoo.org>
Sun, 10 May 2020 09:42:44 +0000 (18:42 +0900)
Closes: https://bugs.gentoo.org/708720
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Akinori Hattori <hattya@gentoo.org>
app-editors/aee/aee-2.2.15b.ebuild
app-editors/aee/aee-2.2.21.ebuild
app-editors/aee/files/aee-gcc-10.patch [new file with mode: 0644]

index 9c78a5318b8ab3f24ee7796b2c879e63d322e3cc..56d77568f79babddcb0733edb0df0d373f2463c4 100644 (file)
@@ -21,6 +21,7 @@ DEPEND="${RDEPEND}"
 PATCHES=(
        "${FILESDIR}"/${P}-ae-location.patch
        "${FILESDIR}"/${PN}-Wformat-security.patch
+       "${FILESDIR}"/${PN}-gcc-10.patch
 )
 DOCS=( Changes README.${PN} ${PN}.i18n.guide ${PN}.msg )
 
index b6b2341baafc1cb3e0c4db3e719cbb783076053a..c6c40f9b214780c4638df8de8d175acd0c40221d 100644 (file)
@@ -21,6 +21,7 @@ DEPEND="${RDEPEND}"
 PATCHES=(
        "${FILESDIR}"/${PN}-ae-location.patch
        "${FILESDIR}"/${PN}-Wformat-security.patch
+       "${FILESDIR}"/${PN}-gcc-10.patch
 )
 DOCS=( Changes README.${PN} ${PN}.i18n.guide ${PN}.msg )
 
diff --git a/app-editors/aee/files/aee-gcc-10.patch b/app-editors/aee/files/aee-gcc-10.patch
new file mode 100644 (file)
index 0000000..c874709
--- /dev/null
@@ -0,0 +1,44 @@
+--- a/Xcurse.c
++++ b/Xcurse.c
+@@ -37,6 +37,8 @@
+ extern int eightbit;
++struct _line *top_of_win;
++
+ static WINDOW *virtual_scr;
+ WINDOW *curscr;
+ WINDOW *stdscr;
+--- a/Xcurse.h
++++ b/Xcurse.h
+@@ -132,7 +132,7 @@
+       int number;
+       };
+-struct _line *top_of_win;
++extern struct _line *top_of_win;
+ typedef struct WIND {
+       int SR;         /* starting row         */
+--- a/new_curse.c
++++ b/new_curse.c
+@@ -85,6 +85,8 @@
+ #endif
++struct _line *top_of_win;
++
+ WINDOW *curscr;
+ static WINDOW *virtual_scr;
+ WINDOW *stdscr;
+--- a/new_curse.h
++++ b/new_curse.h
+@@ -161,7 +161,7 @@
+       int number;
+       };
+-struct _line *top_of_win;
++extern struct _line *top_of_win;
+ typedef struct WIND {
+       int SR;         /* starting row         */