dev-python/pathlib2: Port to py39
authorMichał Górny <mgorny@gentoo.org>
Wed, 27 May 2020 05:46:02 +0000 (07:46 +0200)
committerMichał Górny <mgorny@gentoo.org>
Wed, 27 May 2020 06:10:51 +0000 (08:10 +0200)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/pathlib2/pathlib2-2.3.5.ebuild

index e080b52fd1ad55f54324fd666489a071cd576c11..fcfb7cdfd59ba85c8428a6b9a8707322878ea3d8 100644 (file)
@@ -3,7 +3,8 @@
 
 EAPI=7
 
-PYTHON_COMPAT=( pypy3 python{2_7,3_{6,7,8}} )
+DISTUTILS_USE_SETUPTOOLS=no
+PYTHON_COMPAT=( pypy3 python{2_7,3_{6,7,8,9}} )
 
 inherit distutils-r1
 
@@ -18,11 +19,10 @@ IUSE="test"
 RESTRICT="!test? ( test )"
 
 RDEPEND="
-       $(python_gen_cond_dep 'dev-python/scandir[${PYTHON_USEDEP}]' -2 )
+       $(python_gen_cond_dep 'dev-python/scandir[${PYTHON_USEDEP}]' -2)
        dev-python/six[${PYTHON_USEDEP}]
 "
 BDEPEND="
-       dev-python/setuptools[${PYTHON_USEDEP}]
        test? (
                ${RDEPEND}
                $(python_gen_cond_dep 'dev-python/mock[${PYTHON_USEDEP}]' -2)