dev-ros/ament_cmake_libraries: use python-any-r1
authorAlexis Ballier <aballier@gentoo.org>
Fri, 13 Dec 2019 12:43:02 +0000 (13:43 +0100)
committerAlexis Ballier <aballier@gentoo.org>
Fri, 13 Dec 2019 13:53:20 +0000 (14:53 +0100)
Package-Manager: Portage-2.3.81, Repoman-2.3.20
Signed-off-by: Alexis Ballier <aballier@gentoo.org>
dev-ros/ament_cmake_libraries/ament_cmake_libraries-0.8.1.ebuild

index 5e721bb81ef3e125a0af262658b364b067532685..b38982c35672fc3637c5d6d40151d23a47e59910 100644 (file)
@@ -5,7 +5,7 @@ EAPI=7
 
 PYTHON_COMPAT=( python{3_6,3_7} )
 
-inherit cmake-utils python-r1
+inherit cmake-utils python-any-r1
 
 ROS_PN="ament_cmake"
 if [ "${PV#9999}" != "${PV}" ] ; then
@@ -30,19 +30,12 @@ else
 fi
 IUSE=""
 
-DEPEND="
-       dev-ros/ament_cmake_core[${PYTHON_USEDEP}]
+RDEPEND="
+       dev-ros/ament_cmake_core
+"
+DEPEND="${RDEPEND}"
+# Deps here are transitive from ament_cmake_core to have matching python support
+BDEPEND="
+       $(python_gen_any_dep 'dev-python/ament_package[${PYTHON_USEDEP}] dev-python/catkin_pkg[${PYTHON_USEDEP}]')
        ${PYTHON_DEPS}
 "
-RDEPEND="${DEPEND}"
-BDEPEND="${DEPEND}"
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-src_configure() {
-       # This is a build tool that does not install python-related files
-       # ... but we need to propagate the deps and use python3 to build it.
-       local pyimpl="${PYTHON_COMPAT[0]}"
-       python_export "${pyimpl}" EPYTHON PYTHON
-       python_wrapper_setup
-       cmake-utils_src_configure
-}