* bump
authorKonstantin V. Arkhipov <voxus@gentoo.org>
Wed, 15 Nov 2006 20:23:29 +0000 (20:23 +0000)
committerKonstantin V. Arkhipov <voxus@gentoo.org>
Wed, 15 Nov 2006 20:23:29 +0000 (20:23 +0000)
Package-Manager: portage-2.1.2_rc1-r7

www-servers/nginx/ChangeLog
www-servers/nginx/files/digest-nginx-0.4.13 [new file with mode: 0644]
www-servers/nginx/nginx-0.4.13.ebuild [new file with mode: 0644]

index b449bd5cb703ea4bb77bfd4de1f29af74481b5bf..1279fdcbd59620b361d13fbd0e97ae7ba98eef9e 100644 (file)
@@ -1,6 +1,12 @@
 # ChangeLog for www-servers/nginx
 # Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/nginx/ChangeLog,v 1.118 2006/10/31 18:22:37 voxus Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/nginx/ChangeLog,v 1.119 2006/11/15 20:23:29 voxus Exp $
+
+*nginx-0.4.13 (15 Nov 2006)
+
+  15 Nov 2006; Konstantin V. Arkhipov <voxus@gentoo.org>
+  -nginx-0.4.12.ebuild, +nginx-0.4.13.ebuild:
+  Version bump.
 
 *nginx-0.4.12 (31 Oct 2006)
 
diff --git a/www-servers/nginx/files/digest-nginx-0.4.13 b/www-servers/nginx/files/digest-nginx-0.4.13
new file mode 100644 (file)
index 0000000..b1d8016
--- /dev/null
@@ -0,0 +1,3 @@
+MD5 d385a1e7a23020d421531818d5606b5b nginx-0.4.13.tar.gz 436610
+RMD160 b8ee35e39c9bdb945aada4271110b36ad24bc3d0 nginx-0.4.13.tar.gz 436610
+SHA256 7f19163e1ee7e2eb85bdf384be4c78755c3ebb50bc13af5fa732399d082ee7a4 nginx-0.4.13.tar.gz 436610
diff --git a/www-servers/nginx/nginx-0.4.13.ebuild b/www-servers/nginx/nginx-0.4.13.ebuild
new file mode 100644 (file)
index 0000000..1140989
--- /dev/null
@@ -0,0 +1,79 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-servers/nginx/nginx-0.4.13.ebuild,v 1.1 2006/11/15 20:23:29 voxus Exp $
+
+inherit eutils
+
+DESCRIPTION="Robust, small and high performance http and reverse proxy server"
+
+HOMEPAGE="http://sysoev.ru/nginx/"
+SRC_URI="http://sysoev.ru/nginx/${P}.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="debug fastcgi imap pcre perl threads ssl zlib"
+
+DEPEND="dev-lang/perl
+       pcre? ( >=dev-libs/libpcre-4.2 )
+       ssl? ( dev-libs/openssl )
+       zlib? ( sys-libs/zlib )
+       perl? ( >=dev-lang/perl-5.8 )"
+
+src_compile() {
+       local myconf
+
+       if use threads; then
+               einfo
+               ewarn "threads support is experimental at the moment"
+               ewarn "do not use it on production systems - you've been warned"
+               einfo
+               myconf="${myconf} --with-threads"
+       fi
+
+       use fastcgi     || myconf="${myconf} --without-http_fastcgi_module"
+       use fastcgi     && myconf="${myconf} --with-http_realip_module"
+       use zlib        || myconf="${myconf} --without-http_gzip_module"
+       use pcre        || {
+               myconf="${myconf} --without-pcre --without-http_rewrite_module"
+       }
+       use debug       && myconf="${myconf} --with-debug"
+       use ssl         && myconf="${myconf} --with-http_ssl_module"
+       use imap        && myconf="${myconf} --with-imap" # pop3/imap4 proxy support
+       use perl        && myconf="${myconf} --with-http_perl_module"
+
+       ./configure \
+               --prefix=/usr \
+               --conf-path=/etc/${PN}/${PN}.conf \
+               --http-log-path=/var/log/${PN}/access_log \
+               --error-log-path=/var/log/${PN}/error_log \
+               --pid-path=/var/run/${PN}.pid \
+               --http-client-body-temp-path=/var/tmp/${PN}/client \
+               --http-proxy-temp-path=/var/tmp/${PN}/proxy \
+               --http-fastcgi-temp-path=/var/tmp/${PN}/fastcgi \
+               --with-md5-asm --with-md5=/usr/include \
+               ${myconf} || die "configure failed"
+
+       emake || die "failed to compile"
+}
+
+src_install() {
+       keepdir /var/log/${PN} /var/tmp/${PN}/{client,proxy,fastcgi}
+
+       dosbin objs/nginx
+       cp ${FILESDIR}/nginx-r1 ${T}/nginx
+       doinitd ${T}/nginx
+
+       rm conf/nginx.conf
+       cp ${FILESDIR}/nginx.conf-r2 ${T}/nginx.conf
+
+       dodir /etc/${PN}
+       insinto /etc/${PN}
+       doins conf/* ${T}/nginx.conf
+
+       dodoc CHANGES{,.ru} LICENSE README
+
+       use perl && {
+               cd ${S}/objs/src/http/modules/perl/
+               make DESTDIR=${D} install || die "failed to install perl stuff"
+       }
+}