dev-python/attr: Initial version
authorManuel Rüger <mrueg@gentoo.org>
Mon, 15 May 2017 14:45:58 +0000 (16:45 +0200)
committerManuel Rüger <mrueg@gentoo.org>
Mon, 15 May 2017 14:45:58 +0000 (16:45 +0200)
Package-Manager: Portage-2.3.5, Repoman-2.3.2

dev-python/attr/Manifest [new file with mode: 0644]
dev-python/attr/attr-0.2.0.ebuild [new file with mode: 0644]
dev-python/attr/metadata.xml [new file with mode: 0644]

diff --git a/dev-python/attr/Manifest b/dev-python/attr/Manifest
new file mode 100644 (file)
index 0000000..d3f8d10
--- /dev/null
@@ -0,0 +1 @@
+DIST attr-0.2.0.tar.gz 1165 SHA256 826135ffdd4d0b4bc8a580ce491c33fd90b55e169217539c34b7bfdbe2086ee3 SHA512 4ba43c3506c91c6a6f19f238a5f0b37ba4ebd2b4cac2b12eda4a6e9f453ff3fa859c4a18cda568bd73a520bc67d89f7a770d9faa7487076dcc505084cb21cc9c WHIRLPOOL 93d9e8252b14960504866909886b3cf13ec618623bd958972a1cd28dd2a77755e5f5d4853057160287bb4aa13cc98e053aaa469a8ce3488ea60f11b542926beb
diff --git a/dev-python/attr/attr-0.2.0.ebuild b/dev-python/attr/attr-0.2.0.ebuild
new file mode 100644 (file)
index 0000000..7664607
--- /dev/null
@@ -0,0 +1,20 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python{3_4,3_5,3_6} )
+inherit distutils-r1
+
+DESCRIPTION="Simple decorator to set attributes of target function or class in a DRY way"
+HOMEPAGE="https://github.com/denis-ryzhkov/attr"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+python_test() {
+       ${EPYTHON} -c "import attr; attr.test()" || die
+}
diff --git a/dev-python/attr/metadata.xml b/dev-python/attr/metadata.xml
new file mode 100644 (file)
index 0000000..b3b13d3
--- /dev/null
@@ -0,0 +1,12 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+  <maintainer type="project">
+    <email>python@gentoo.org</email>
+    <name>Python</name>
+  </maintainer>
+  <upstream>
+    <remote-id type="pypi">attr</remote-id>
+    <remote-id type="github">denis-ryzhkov/attr</remote-id>
+  </upstream>
+</pkgmetadata>